Issue 97552 - Insert Object document with password as a link, input wrong password and Cancle crashes Drawing and Impress
Summary: Insert Object document with password as a link, input wrong password and Canc...
Status: CLOSED FIXED
Alias: None
Product: Draw
Classification: Application
Component: code (show other issues)
Version: DEV300m37
Hardware: All All
: P2 Trivial (vote)
Target Milestone: OOo 3.1
Assignee: wolframgarten
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks: 84292
  Show dependency tree
 
Reported: 2008-12-24 06:51 UTC by amy2008
Modified: 2009-02-16 16:57 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
document with password (11.07 KB, application/vnd.oasis.opendocument.text)
2008-12-24 06:53 UTC, amy2008
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description amy2008 2008-12-24 06:51:48 UTC
Can reproduce it with DEV300m37 on WinXP and Fedora

How to reproduce it
1 Open a new Drawing or Impress document
2 Insert - Object - OLE Object - Create from file: Check 'Link to file' and
  search for a document saving with password, then 'OK', Password dialog opens
3 Input a wrong password or input nothing, OK, the hint 'The wrong password has
  been entered' shows, OK
4 Password dialog opens once more, Cancel
5 'Runtime error' dialog opens, OK

Result
On Fedora, OOo crashes after step 4
On WinXP,  OOo crashes after step 5

Expectation
Drawing or Impress works well

Attachment file password: 111111

Regards
Li Meiying
Comment 1 amy2008 2008-12-24 06:53:27 UTC
Created attachment 58991 [details]
document with password
Comment 2 wolframgarten 2009-01-05 14:32:55 UTC
Reproducible. Reassigned.
Comment 3 groucho266 2009-01-12 12:11:53 UTC
The crash is caused by an uncaught exception.  When the file is not properly
unlocked a css::uno::Exception is thrown.  The exception is not caught which
leads directly to a crash under the unixes.  On windows there "just" is a
corrupt object which leads to a crash later.

Fixed by catching css::uno::Exception in FuInsertOLE::DoExecute(SfxRequest&).

Modified file is
/sd/source/ui/func/fuinsert.cxx    rev. 266153
Comment 4 groucho266 2009-01-21 12:15:21 UTC
@WG: Please verify.
Comment 5 groucho266 2009-01-21 12:16:21 UTC
See above.
Comment 6 wolframgarten 2009-01-26 14:44:52 UTC
Verified in CWS.
Comment 7 wolframgarten 2009-02-16 16:57:13 UTC
Tested in OOO310_m1. Closed.