Issue 97571 - Impress hung when double right-click on Adding "Custom Animation"
Summary: Impress hung when double right-click on Adding "Custom Animation"
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: editing (show other issues)
Version: OOO300m9
Hardware: Unknown All
: P2 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: wolframgarten
QA Contact: issues@graphics
URL:
Keywords: crash
Depends on:
Blocks: 84292
  Show dependency tree
 
Reported: 2008-12-25 05:54 UTC by doze_worm
Modified: 2009-05-20 10:57 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description doze_worm 2008-12-25 05:54:23 UTC
[Steps]
1. Create a blank Impress doc.
2. Insert an object from "insert" menu, e.g. a chart or a table.
3. Choose the object, select "Custom Animation" from "Tasks" bar, left-click
"Add..." button, double right-click any item in the pop-up "Custom Animation"
Dialogbox, such as "Appear" in "Entrance" bar.

[Result]
Background bacomes black, the program lose response.

[Expectation]
No action
Comment 1 kpalagin 2008-12-26 13:00:00 UTC
Confirming with m37 on WinXP - Impress goes into loop, consuming 100% CPU.

doze_worm,
good job!!
Comment 2 wolframgarten 2009-01-05 14:15:42 UTC
Reproducible. Reassigned. Already happening in 2.4.1.
Comment 3 groucho266 2009-04-06 12:19:29 UTC
I think that I have seen a similar (or event he same?) issue elsewhere but can't
find it.
Comment 4 groucho266 2009-04-06 12:22:02 UTC
The crash is caused by infinite recursion in CategoryListBox::MouseButtonUp()
where right clicks are forwarded to the same class instead of the parent class.

Fixed by fixing the forwarding of CategoryListBox::MouseButtonUp() to the base
class.

Revision of the fix is 270538.
Comment 5 groucho266 2009-04-24 12:43:45 UTC
@wg: Please verify.
Comment 6 wolframgarten 2009-04-27 12:19:35 UTC
Verified in CWS.
Comment 7 wolframgarten 2009-05-20 10:57:09 UTC
Tested in m48. Closed.