Issue 97589 - Serious efficience problem when fill the whole sheet, lead to block
Summary: Serious efficience problem when fill the whole sheet, lead to block
Status: CLOSED DUPLICATE of issue 59453
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOO300m9
Hardware: Unknown All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks: 84292
  Show dependency tree
 
Reported: 2008-12-26 09:27 UTC by doze_worm
Modified: 2009-04-27 06:09 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description doze_worm 2008-12-26 09:27:40 UTC
[Steps]
1. Create a Calc doc.
2. Input a word into A1 cell, select the 1st line, "Edit -> Fill -> Right"
3. Select the whole sheet, "Edit -> Fill -> Down"

[Result]
Waiting for long time. After the process bar shows filling complete ,program
lost response.
I can see my 3Gigabyte memory + 4Gigabyte swap has been exhausted.

[Expectation]
Improve the fill algorithm.
Comment 1 kpalagin 2008-12-30 13:06:19 UTC
I still beleive this is dup of 59453.
Comment 2 amy2008 2009-04-27 06:08:48 UTC
Accept
Duplicate to issue 59453

*** This issue has been marked as a duplicate of 59453 ***
Comment 3 amy2008 2009-04-27 06:09:19 UTC
Closing