Issue 97630 - Loop when pasting or deleting specific string multiply
Summary: Loop when pasting or deleting specific string multiply
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: DEV300m37
Hardware: Unknown All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords: needmoreinfo, oooqa
Depends on:
Blocks: 84292
  Show dependency tree
 
Reported: 2008-12-29 07:06 UTC by doze_worm
Modified: 2009-08-11 17:20 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
A screen record of the process of reproducing the problem. Open with Firefox. (727.69 KB, text/rtf)
2009-01-21 08:06 UTC, doze_worm
no flags Details
A new screen record. At the point when paste a whole line, the program lost responding. Then right/left click will lead to nothing. Close the program forcely. (231.60 KB, text/rtf)
2009-01-21 09:30 UTC, doze_worm
no flags Details
The programs installed on my system (69.60 KB, image/jpeg)
2009-02-04 03:08 UTC, doze_worm
no flags Details
Windows system properties (31.41 KB, text/plain)
2009-02-04 03:09 UTC, doze_worm
no flags Details
Task list when the loop occurs. (69.60 KB, text/plain)
2009-02-04 03:09 UTC, doze_worm
no flags Details
Programs installed on my system. And please omit attach id=59886 (49.83 KB, image/jpeg)
2009-02-04 03:17 UTC, doze_worm
no flags Details
The services and Input Languages setting. (44.76 KB, image/jpeg)
2009-02-04 03:21 UTC, doze_worm
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description doze_worm 2008-12-29 07:06:26 UTC
[Steps]
1. Create a Writer doc.
2. Type in the following string(without quotation marks) : "123what"
3. Select the whole string, press "Ctrl + c", then keep pressing "Ctrl + v".
4. If not block in step 3, keep press "Backspace".

[Result]
In DEV300m37 (Windows XP), the block phenomenon appears in a high rate, which is
over 50%. And the CPU using is 100% when it happens.
But it cannot be reproduced in DEV300m35 (Linux).

[Addition]
Besides "123what", "121test" can lead to the same result.
Comment 1 amy2008 2008-12-31 02:06:35 UTC
Reproducible with DEV300m37 on WinXP and Fedora
Li Meiying
Comment 2 michael.ruess 2009-01-09 14:42:04 UTC
I cannot reproduce with DEV300m38. Could you please recheck? Thanks!
Comment 3 michael.ruess 2009-01-16 10:39:45 UTC
Cannot reproduce with DEV300m38.
Comment 4 michael.ruess 2009-01-16 10:40:15 UTC
Closed.
Comment 5 doze_worm 2009-01-21 08:06:46 UTC
Created attachment 59549 [details]
A screen record of the process of reproducing the problem. Open with Firefox.
Comment 6 doze_worm 2009-01-21 08:18:58 UTC
It needs to do three, four or even more times to reproduce the problem. In the
screen record, which I upload as an attachment, I still keep pressing "Ctrl + v"
every time when I create a new writer doc.

I've tested it on DEV300m39 on both WinXP and Linux. And it can only be
reproduced in Windows. 
Would you take a look at it.
Comment 7 amy2008 2009-01-21 08:23:11 UTC
Meiying -> MRU
I have checked it with DEV300m39 on WinXP, reproducible. See attachment.
If can't reproduce it, please remove the configure documents in
C:\Documents and Settings\*computer username*\Application Data\dev or OOo 
document, then check it again.

Regards
Comment 8 eric.savary 2009-01-21 09:01:01 UTC
I cannot reproduce it (on Vista with 3.0 or m39).
What do you mean with "block"? A crash? A freeze?

The attached movie shows neither a crash nor a freeze: at the end, the document
can be normally closed.

Else, I didn't notice any abnormal CPU activity while pasting.
Please detail.
Comment 9 doze_worm 2009-01-21 09:21:39 UTC
"block" means the program has no response. I didn't discribe clearly. I'm sorry.
Please notice the "(Not Responding)" words in title bar at the end of the movie.
It cannot be close normally, but at that point, the movie switch to the
beginning by cycle display.

I'll upload a new one. 
Comment 10 doze_worm 2009-01-21 09:30:05 UTC
Created attachment 59553 [details]
A new screen record. At the point when paste a whole line, the program lost responding. Then right/left click will lead to nothing. Close the program forcely.
Comment 11 michael.ruess 2009-01-22 11:17:34 UTC
I performed exactly the steps you described, but Writer did not end up in a loop
here. So we got to find out what the differences are between our two
environments. I do not have an idea, why this leads to a hang on yours...
Comment 12 eric.savary 2009-01-23 18:15:51 UTC
As MRU said, there must be something specific but common to your (doze_worm and
 amy2008) both environments (unless you use the same machine).

So please check following things and change some of those parameters to see if
it may be the source of the problem:

1) external programs working in the background (anti virus programs, desktop
enhancer, input or clipboard tools, etc...) try to see if this is still
reproducible when you switch them off.

2) locales and input: please check and change the document language (maybe an
auto spellcheck leads to performance problem), the input method/language (i.e.
when inputing Latin but with Chineese IME only?)

3) Clipboard: any clipboard enhancer? Do you work locally or via VNC or rdesktop
(try to kill the rdpclip.exe task), Virtual Machine?

Else I have no idea... :)
Comment 13 eric.savary 2009-02-03 16:59:16 UTC
Feel free to reopen when you have more information.
Comment 14 eric.savary 2009-02-03 16:59:52 UTC
closed
Comment 15 doze_worm 2009-02-04 03:07:34 UTC
I've remove all the anti-virus program, input-method program and MS office on my
comptuer. The system is Windows XP sp3 (ENU) and the OO program is
DEV300_m41_en-US (complete install). But the problem still occurs.

I'll upload several screen-shots about the environment of my system.
Could you take a look at this. I've no idea about what's the difference of the
system between yours and mine and why you cannot reproduce it.
Comment 16 doze_worm 2009-02-04 03:08:35 UTC
Created attachment 59886 [details]
The programs installed on my system
Comment 17 doze_worm 2009-02-04 03:09:17 UTC
Created attachment 59887 [details]
Windows system properties
Comment 18 doze_worm 2009-02-04 03:09:53 UTC
Created attachment 59888 [details]
Task list when the loop occurs.
Comment 19 doze_worm 2009-02-04 03:17:02 UTC
Created attachment 59889 [details]
Programs installed on my system. And please omit attach id=59886
Comment 20 doze_worm 2009-02-04 03:21:53 UTC
Created attachment 59890 [details]
The services and Input Languages setting.
Comment 21 doze_worm 2009-02-04 05:39:37 UTC
I've redo the test in a totally new system without any drivers or applications
installed but OOo-DEV300m41. The result was the same. When kept pasting for a
while, usually no more than 3 lines, the OOo looped and lost response. (If
pasting over 5 lines and the problem doesn't occur, you need to close the Writer
doc and create a new one, then keep pasting.)

And this problem only occurs in Windows. In Linux, it works well.

Regards.
Comment 22 eric.savary 2009-02-16 13:38:31 UTC
Please try *everything* (each remark, question, supposition from 1, 2 and 3) I
asked you else we cannot surround the problem.
Also for example, from your screenshot I see the Chinese Kbd layout. Did you try
the same with EN_US keyboard layout?
Comment 23 eric.savary 2009-03-01 11:49:51 UTC
Closing while no further information.
Comment 24 eric.savary 2009-03-01 11:50:30 UTC
Closed
Comment 25 doze_worm 2009-03-02 02:48:19 UTC
@es: I ever tried to install an ENU Windows XP without "Install files for East
Asian languages" Option in "Regional and Language Options" of the system. But
the problem still exists in DEV300m37, DEV300m39 and DEV300m41.

It is really queer that I cannot reproduce it in DEV310m2 on Linux or Windows
eather. So just leave it as closed. 

Regards.
Comment 26 demolish 2009-08-11 17:20:44 UTC
This bug still exists in version 3.1.0 (OO0310m11 build: 9399)
Basically I had 2 OO documents open, I was cutting and pasting between the two
and after copying some text, via ctrl-c, OO hung - the hour glass appeared and
never went away, and the application became non-responsive. I have the MS dump
of the application if that is of any help. It is not reliably reproducible,
however it is always with cut and paste and is the exact same problem noted in
previous versions.
I previously reported this bug in issue: 99793. That issue was closed with
reference to this one. Hence why I am commenting on this issue.
I don't have any clipboard tools installed, I have installed OO on a new PC
since my previous post on this issue. Anti-virus software is AVG. Nothing out of
the ordinary installed on this PC. I am running as a dumb user, i.e. no admin.
rights.