Issue 97650 - Writer block: paste a web page, then set page columns
Summary: Writer block: paste a web page, then set page columns
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOO300m9
Hardware: Unknown All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks: 84292
  Show dependency tree
 
Reported: 2008-12-30 02:16 UTC by doze_worm
Modified: 2017-05-20 11:18 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
the html file to reproduce the problem, need to uncompress (13.79 KB, text/plain)
2008-12-30 02:19 UTC, doze_worm
no flags Details
the html file to reproduce the problem, need to uncompress (13.79 KB, text/plain)
2008-12-30 02:28 UTC, doze_worm
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description doze_worm 2008-12-30 02:16:57 UTC
[Steps]
1. Create a writer doc
2. Open the html file, which has been uploaded as an attachment, with a web
browser, "Ctrl + a" and "Ctrl + c" to copy the whole page. Then switch to the
writer, "Ctrl + v" to paste in.
3. In writer doc, right click -> "Page...", choose "Columns" bar in the pop-up
dialogbox, select the last one of the five styles in "Settings" region, press OK
button.

[Result]
Program block and lose response.

[Expectation]
Program runs normally.
Comment 1 doze_worm 2008-12-30 02:19:36 UTC
Created attachment 59064 [details]
the html file to reproduce the problem, need to uncompress
Comment 2 doze_worm 2008-12-30 02:28:49 UTC
Created attachment 59065 [details]
the html file to reproduce the problem, need to uncompress
Comment 3 doze_worm 2008-12-30 02:31:47 UTC
sorry, the network connection is broken, resend a duplicate attachment
Comment 4 amy2008 2008-12-31 01:52:04 UTC
Reproducible with DEV300m37 on WinXP and Fedora.
Comment 5 eric.savary 2009-01-13 11:51:39 UTC
@OD: I couldn't "surround" the problem. I only noticed that the loop only
happens when the cursor is at the bottom of the document.
Comment 6 Oliver-Rainer Wittmann 2009-01-15 13:06:26 UTC
First investigation reveals a layout-loop during the table formatting.

But, I judge this case as a rare one. Thus, I lowered the priority and changed
the target.
Comment 7 Marcus 2017-05-20 11:18:18 UTC
Reset assigne to the default "issues@openoffice.apache.org".