Issue 97654 - Writer: serious efficiency defect when open large pure-text .doc file
Summary: Writer: serious efficiency defect when open large pure-text .doc file
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOO300m9
Hardware: Unknown All
: P2 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks: 84292
  Show dependency tree
 
Reported: 2008-12-30 06:59 UTC by doze_worm
Modified: 2017-05-20 11:13 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
the MS Word doc to reproduce the problem. Need to uncompress. (966.01 KB, text/plain)
2008-12-30 07:05 UTC, doze_worm
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description doze_worm 2008-12-30 06:59:47 UTC
[Steps]
1. Open the 800pages_pure_text.doc file which uploaded as attachment.

[Result]
Consuming more than 20 minutes to open it. While MS Word needs less than 10 seconds.
(CPU: T5760 1.8G ; MEM: DDR2 667MHz 3GB)
So the formating module has serious efficient problem when translating the MS
Word doc format.

[Expectation]
To reduce the open time to an acceptable value.

[Addition]
One my personal suggestion(Just for your reference): When the several pages in
front have been formated, open the program and show them, as the same time to
format the rest.
Comment 1 doze_worm 2008-12-30 07:05:44 UTC
Created attachment 59070 [details]
the MS Word doc to reproduce the problem. Need to uncompress.
Comment 2 amy2008 2008-12-31 01:41:43 UTC
Can Reproduce it with DEV300m37 on WinXP and Fedora

Li Meiying
Comment 3 gibi 2008-12-31 23:18:37 UTC
Reproduced with 3.0.1rc1 Linux X64.

21 minutes to open with Core2 Duo CPU T7500  @ 2.20GHz

saved as .odt : reopened in a few seconds

Importing issue?
Comment 4 michael.ruess 2009-01-09 17:22:21 UTC
MRU->HBRINKM: pls have a look, maybe it is the same problem as issue 75939 or
issue 76955. Thanks!
Comment 5 Marcus 2017-05-20 11:13:31 UTC
Reset assigne to the default "issues@openoffice.apache.org".