Issue 97744 - Header and Footer failure when save a writer doc as ".doc" file type which contents "Indexes and Tables" in first line
Summary: Header and Footer failure when save a writer doc as ".doc" file type which co...
Status: CLOSED DUPLICATE of issue 90073
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOO300m9
Hardware: Unknown All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks: 84292
  Show dependency tree
 
Reported: 2009-01-04 09:28 UTC by doze_worm
Modified: 2009-06-27 08:17 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description doze_worm 2009-01-04 09:28:07 UTC
[Steps]
1. Create a writer doc
2. Type several paragraphs, and Use a "Style and Formatting" on then, such as
"Heading 1"
3. Put the cursor at the beginning of the first paragraph, "Ctrl + Enter" to
move then on the 2nd page. From top menu, "Insert" -> "Indexes and Tables" ->
"Indexes and Tables...", click OK button on the "Insert Index/Table" dialog.
4. "Insert" -> "Header" -> "default", type some words in header field
5. "Insert" -> "Footer" -> "default", type some words in footer field
6. "File" -> "Save" to save the file as type as "Microsoft Word 97/2000/XP".
7. "File" -> "Reload", observe the result.
8. Open the saved file by MS Word, observe the result.

[Result]
In step 7: The words in Header and Footer disappear except first page.
In step 8: The Header and Footer field has been disabled, neither seen nor edit.

[Expectation]
Header and Footer display normally.
Comment 1 michael.ruess 2009-01-06 13:22:37 UTC
Already tracked as issue 90073.

*** This issue has been marked as a duplicate of 90073 ***
Comment 2 michael.ruess 2009-01-06 13:23:14 UTC
Closing duplicate.
Comment 3 jmaechtlen 2009-06-27 08:17:43 UTC
Part of the problem is the section breaks added in the conversion process.
Each table of contents/figures gets a continuous section break before the title
of the table, between the title and the table, and at the end of the table.
Each of those section breaks offer a chance to trash the headers and footers.