Issue 97847 - export PDF does not export TOC in pdf file
Summary: export PDF does not export TOC in pdf file
Status: CLOSED DUPLICATE of issue 3356
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOO300m9
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-07 18:28 UTC by bean66
Modified: 2009-01-23 21:14 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
odt file that contains the issue (57.91 KB, text/plain)
2009-01-07 18:29 UTC, bean66
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description bean66 2009-01-07 18:28:26 UTC
The document has a Table Of Contents on the 3rd page.

Export to PDF does not export the PDF with a bookmarks from the TOC.
Comment 1 bean66 2009-01-07 18:29:07 UTC
Created attachment 59223 [details]
odt file that contains the issue
Comment 2 bean66 2009-01-07 18:30:03 UTC
just export the file to pdf. 
Open pdf and observe that the pdf is missing bookmarks for the toc
Comment 3 jbf.faure 2009-01-18 08:55:19 UTC
It works well if you do Tools > Chapter numbering. After having done that you
can see chapter titles in the navigator window.

kind regards
JBF
Comment 4 eric.savary 2009-01-23 18:58:30 UTC
@jbfaure: Thanx! That's the workaround for issue 3356.

*** This issue has been marked as a duplicate of 3356 ***
Comment 5 eric.savary 2009-01-23 18:59:06 UTC
Closed
Comment 6 bean66 2009-01-23 19:48:47 UTC
I see no option uner tools called chapter numbering! 
Exactly where is that option?

Thanks
Comment 7 eric.savary 2009-01-23 19:53:48 UTC
"Outline numbering"

*** This issue has been marked as a duplicate of 3356 ***
Comment 8 eric.savary 2009-01-23 19:54:05 UTC
Closed
Comment 9 bean66 2009-01-23 20:08:17 UTC
OK,
I needed to go to tools, outline numbering. Then for each of the numbers 1, 
2 ... (levels) I needed to select in the pull down the "heading 1", "heading 2" 
to correspond with each level. Then it worked!

I still don't know why it did't just pick this up from the word document! And 
set itself up properly. The word docs Toc is fine and exports to PDF fine.
Comment 10 eric.savary 2009-01-23 21:13:12 UTC
Yes and for this you didn't need to reopen 2 times this issue...!
Comment 11 eric.savary 2009-01-23 21:13:31 UTC
Closed
Comment 12 eric.savary 2009-01-23 21:14:00 UTC
.

*** This issue has been marked as a duplicate of 3356 ***
Comment 13 eric.savary 2009-01-23 21:14:13 UTC
Closed