Issue 97857 - Dropdown list shows number format after setting validity as Date
Summary: Dropdown list shows number format after setting validity as Date
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: DEV300m37
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords:
: 102537 (view as issue list)
Depends on:
Blocks: 84292
  Show dependency tree
 
Reported: 2009-01-08 05:45 UTC by amy2008
Modified: 2013-08-07 15:14 UTC (History)
7 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
The patch of this issue. (5.95 KB, text/plain)
2009-04-02 10:24 UTC, gaojingmei
no flags Details
the updated patch for this issue (3.97 KB, text/plain)
2009-04-03 03:56 UTC, gaojingmei
no flags Details
the updated patch of this issue (1.85 KB, text/plain)
2009-04-22 06:46 UTC, gaojingmei
no flags Details
the updated patch for this issue, but it doesn't still work for external reference and a formula (2.43 KB, text/plain)
2009-04-28 09:18 UTC, gaojingmei
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description amy2008 2009-01-08 05:45:29 UTC
Can reproduce it with DEV300m37 on WinXP and Fedora

How to reproduce it
1 Create a new Calc document
2 Select A1, right_click and Format cells, switch to Numbers - Date (select one
  format like ****/**/** ), enter date e.g. 2008-12-5 in A1
3 Select another cell b2, Data - Validity - Criteria Allow as 'Cell Range', 
  Source as 'A1' - OK
4 Click Dropdown list

Result
Find list item is number format

Expectation
List item is Date format

Regards
Meiying
Comment 1 cno 2009-02-20 23:11:32 UTC
Hi Meiying,
I also see this in OOo 3.0.1
The number we see of course is the internal number representation of the date in A1
(Related (already so for a long time): when you want to enter a date as criteria
for validation, you have to enter the number representation.
Comment 2 gaojingmei 2009-04-02 10:24:33 UTC
Created attachment 61356 [details]
The  patch of  this issue.
Comment 3 gaojingmei 2009-04-03 03:56:27 UTC
Created attachment 61373 [details]
the updated patch for this issue
Comment 4 gaojingmei 2009-04-22 06:46:46 UTC
Created attachment 61719 [details]
the updated patch of this issue
Comment 5 gaojingmei 2009-04-28 09:18:48 UTC
Created attachment 61865 [details]
the updated patch for this issue, but it doesn't still work for external reference and a formula
Comment 6 niklas.nebel 2009-05-05 17:27:26 UTC
taking the issue
Comment 7 niklas.nebel 2009-05-05 17:33:29 UTC
I added the last patch to CWS "calc50".
Comment 8 niklas.nebel 2009-05-28 15:21:11 UTC
reassigning to QA for verification
Comment 9 oc 2009-06-08 10:08:21 UTC
*** Issue 102537 has been marked as a duplicate of this issue. ***
Comment 10 oc 2009-06-08 10:42:55 UTC
verified in internal build cws_calc50
Comment 11 amy2008 2009-07-10 07:27:36 UTC
Verified in DEV300m51
Closing
Comment 12 Joe Smith 2009-08-28 17:36:44 UTC
This is still not working for me, testing m54 on Fedora Linux.

Should I start a new issue, or is there some integration detail that I've missed?
Comment 13 Joe Smith 2009-09-15 15:41:16 UTC
Testing DEV300_m58 on Linux (Fedora 11):

Looks ok now: the dropdown shows formatted dates instead of serial dates.

Thanks!