Issue 97972 - Added drawing features for OOo Impress
Summary: Added drawing features for OOo Impress
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: code (show other issues)
Version: DEV300m34
Hardware: All All
: P3 Trivial with 7 votes (vote)
Target Milestone: OOo 3.3
Assignee: eric.bachard
QA Contact: issues@graphics
URL: https://pedagogie.ec-nantes.fr/tablet...
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-12 08:42 UTC by ssaboum
Modified: 2017-05-20 10:22 UTC (History)
8 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
patch to this graphic issue (25.66 KB, text/plain)
2009-01-12 08:45 UTC, ssaboum
no flags Details
Test Document for test case specification (11.03 KB, text/plain)
2009-01-28 14:54 UTC, fredus
no flags Details
Test case specification (4.25 KB, text/plain)
2009-01-28 15:29 UTC, fredus
no flags Details
Test case specification with good MIME type (4.25 KB, text/html)
2009-01-28 15:33 UTC, fredus
no flags Details
Test Case for annotations persistence (3.93 KB, text/html)
2009-03-19 09:08 UTC, fredus
no flags Details
Test Case for annotations saving (4.47 KB, text/html)
2009-03-19 09:10 UTC, fredus
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description ssaboum 2009-01-12 08:42:58 UTC
Seven students from the Ecole Centrale de Nantes(France) worked on a way to make
OpenOffice better interact with tablet-pc features, and enhanced the drawing
features there already was.

We added, with many help from ericb2 and thorsten, the possibility to change
stroke color and width during a slideshow, when the "mouse as a pen" feature is
activated.
The patch presented here was mainly written by Frédéric Gelot(aka fredus), and a
little by me, at that time we used the DEV300_m34 tag to work.
We mainly reviewed this code under Ubuntu 8.04 and 7.10, and would love more
feedback.
Thank you for taking this into account.

Ssaboum
Comment 1 ssaboum 2009-01-12 08:45:16 UTC
Created attachment 59315 [details]
patch to this graphic issue
Comment 2 eric.bachard 2009-01-12 09:09:26 UTC
Hi Olivier :-)

Thanks for attaching the patch. FYI, since you have commit rights, it could be great to create your own 
cws (I can help you) 

Eric

Issue confirmed -> New
Comment 3 eric.bachard 2009-01-12 10:44:41 UTC
Excepted french comments in the patch, the code looks good. What is needed to test it ? (I got an Intuos 
tablet at hand, will it work ? )
Comment 4 ssaboum 2009-01-12 11:44:49 UTC
if the tablet is recognized by the os, it will work, right now there is no
particular code associated to whether or not it is a tablet. Our patch works
even with a simple mouse, it's just easier to draw with a tabletpc.
Comment 5 eric.bachard 2009-01-12 12:21:43 UTC
@ssaboum : I'll give it a try :-)


Comment 6 kpalagin 2009-01-16 04:59:13 UTC
Is this issue related to http://www.openoffice.org/issues/show_bug.cgi?
id=10922 ?
Comment 7 ssaboum 2009-01-16 07:10:00 UTC
yes, actually we added the features they wanted, with this patch you can change
stroke color and width easily during a slideshowwith Impress
Comment 8 ronnystandtke 2009-01-16 09:41:22 UTC
Wow, thank you so much. This is one of the features I have been really waiting for!
Comment 9 kpalagin 2009-01-16 10:53:41 UTC
ssaboum,  ericb,
make sure that somebody from Graphics team (either cl or ka) is on CC and keep 
pushing for integration - UI freeze for 3.2 is not that far away (I assume 
that your patch touches UI. if it does not then try integrating it in 3.1, 
which will be codefreezed at 29th of Jan).

Thanks a lot for your effort.
Comment 10 eric.bachard 2009-01-19 00:40:07 UTC
Tested the code with m39 on Mac Intel ( cariro enabled) and the mouse: very good work. I was able to 
change the pen width/color very easely.

Next suggested steps : 

- (please) create associated specs. Real specs is the right way, but at least create a wiki page like (e.g. http://wiki.services.openoffice.org/wiki/Mac_OS_X_Porting_-_Apple_Remote_implementation )
- create a cws
- commit
- improve the code 
- think to localization (currently, not correct)
- (complete)

Comment 11 fredus 2009-01-19 08:55:53 UTC
ericb, thanks for the tests.

We will make specs asap. Do we gather specs for all functionalities that we
developed and that we will develop (the new project) ?

I have retrieved the official specification template.
Then, we need a QA representative to form a i-team.

I tried also to create a CWS but I'd got an error because CWS needs an encrypted
CVS_PASSWORD. But I use SVN and not CVS.

Thanks for your help.

Comment 12 eric.bachard 2009-01-19 09:07:35 UTC
Hi Frédéric :)

I'll help you on the #education.openoffice.org channel, and we'll see together what is the problem.

FYI, I'm in touch with Christian Jansen, about how proceed for specs, and QA. Stay tuned :)
Comment 13 fredus 2009-01-28 14:54:51 UTC
Created attachment 59723 [details]
Test Document for test case specification
Comment 14 fredus 2009-01-28 15:29:08 UTC
Created attachment 59724 [details]
Test case specification
Comment 15 fredus 2009-01-28 15:33:01 UTC
Created attachment 59725 [details]
Test case specification with good MIME type
Comment 16 fredus 2009-03-19 09:08:50 UTC
Created attachment 61028 [details]
Test Case for annotations persistence
Comment 17 fredus 2009-03-19 09:10:14 UTC
Created attachment 61029 [details]
Test Case for annotations saving
Comment 18 brad_richards 2009-11-10 18:38:24 UTC
Please don't let this issue die! Those of us who use Impress in academia are
waiting in despondent silence - since the first request some 5 years ago. With
this patch, we are finally close to a solution!
Comment 19 jonwinandy 2009-11-12 16:56:55 UTC
I am a part of a group of students (from Ecole Centrale de Nantes too) who are taking care of the 
integration of this patch in the trunk.

It's still a work in progress. Olivier and Fred did a great work, but it matches not yet openoffice 
standards. Then we are fixing that ;)

Thank you for your interrest in this issue, I can confirm it's not dying.

Best regards,
Jonathan


Thanks Fred for the nudge
Comment 20 eric.bachard 2009-12-15 22:48:07 UTC
New changes commited in eraser01 (mercurial)

Will try both feature enabled and feature disabled builds to be sure.



Comment 21 eric.bachard 2010-01-06 15:46:15 UTC
Issue fixed in eraser01. Commits done.

See : changeset 262771	36d89f0ce761

Comment 22 eric.bachard 2010-01-06 15:57:35 UTC
Setting the right target
Comment 23 gleppert 2010-06-18 07:42:22 UTC
Is this feature on track for release 3.3? "Highlighting in presentation mode"
just got deleted from the wiki page mentioning the features for 3.3:
http://wiki.services.openoffice.org/wiki/Features
Thanks