Issue 98058 - "Similarity search" leads to search failure in Calc
Summary: "Similarity search" leads to search failure in Calc
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOo 3.2.1 RC1
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
Depends on:
Blocks: 84292
  Show dependency tree
Reported: 2009-01-14 09:13 UTC by doze_worm
Modified: 2013-01-29 21:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Calc doc for producing the problem. it only contains several words. (7.26 KB, application/vnd.oasis.opendocument.spreadsheet)
2009-01-14 09:17 UTC, doze_worm
no flags Details
A screen record for producing the problem. Open with Firefox. (943.28 KB, text/rtf)
2009-01-15 05:49 UTC, doze_worm
no flags Details
submit again, correct the MIME type (943.28 KB, flash/swf)
2010-05-10 03:24 UTC, doze_worm
no flags Details
Pleash omit the 2nd and the 3rd attachments (943.28 KB, application/x-shockwave-flash)
2010-05-10 03:30 UTC, doze_worm
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description doze_worm 2009-01-14 09:13:01 UTC
1. Open the Calc doc in attachment.
2. "Ctrl + F", pop-up the "Find & Replace" dialog-box. Click "More Options"
button on it, enable the "Similarity search" checkbox, and press "..." button to
open the "Similarity Search" dialog-box, make sure the Settings is as follow
(default value):
   Exchange characters     2
   Add characters          2
   Remove characters       2
   Combine (checkbox)      enabled
3. Back to "Find & Replace" dialog-box, search "crack", "black", "blacker" and
"ack" respectively.

Cannot find "crack", "black" and "blacker" at all, no matter setting which value
of "Search in" drop-list or selecting "Rows" or "Columns" in "Search direction".
Only string "ack" can be found.

Find & Replace works correctly when "Similarity search" has been enabled.

If unselect the "Similarity search" checkbox, the string "black" and "ack" can
be found.
Comment 1 doze_worm 2009-01-14 09:17:09 UTC
Created attachment 59375 [details]
Calc doc for producing the problem. it only contains several words.
Comment 2 ooo 2009-01-14 19:01:00 UTC
Can't confirm. Matching results, where applicable, are found for each of the
listed words:
crack black blacker ack

Tried with both, Solaris/x86 OOO300_m9 and Linux/x86 DEV300_m38 builds.
Comment 3 doze_worm 2009-01-15 05:45:42 UTC
Change the title, only Calc has the problem.
I've tested both on DEV300m37 WinXP and DEV300m38 Linux. I'll upload a screen
record of it.
Comment 4 doze_worm 2009-01-15 05:49:09 UTC
Created attachment 59389 [details]
A screen record for producing the problem. Open with Firefox.
Comment 5 Mechtilde 2009-07-12 19:53:10 UTC
worksforme -> closed
Comment 6 amy2008 2009-08-05 06:52:23 UTC
Can reproduce it in DEV300m54. 
Pls see the second attachment file issue98058-process.swf with flash player
Comment 7 amy2008 2009-08-05 06:56:15 UTC
Comment 8 thackert 2009-12-22 18:39:08 UTC
Hello doze_worm,
I cannot confirm your issue with Germanophone version of OOO320m8 (3.2.0 RC1)
under Debian SID AMD64 ... :( I found all the words and more without any
problem. Could you test it with a newer version as well, please?
Have fun
Comment 9 doze_worm 2009-12-23 01:47:40 UTC
I cannot reproduce it in DEV300m67 or OOO320m8, either.
So leave it as closed.
Comment 10 doze_worm 2009-12-23 01:48:40 UTC
Change to closed.
Comment 11 doze_worm 2009-12-23 02:10:46 UTC
Sorry to bother. But it do has problem as discribed in the very first comment.
And it can only be reproduced in Windows system. In Linux, it works well.
(Version: DEV300m67 OOO320m8)
Could you try it again?
Comment 12 thackert 2010-01-17 16:18:22 UTC
Hello doze_worm,
I have tried it again, but as I only has Debian SID AMD64 installed, I cannot
test it for Win ... :( But if you think, it is only M$ related, you should
change OS to Windows $version instead of marking it as an issue for all OSes ...
;) On my system with Debian SID AMD64, KDE 4.3.4-1 and the Germanophone version
of OOO320m9 it works ... ;) And er has reported, that it works with Solaris as
well ...
Have fun
Comment 13 redflagzhulihua 2010-01-19 03:14:37 UTC
And doze_worm is in his vacation too. I'm taking his part. ;-)
Comment 14 thackert 2010-05-09 18:38:16 UTC
Hello doze_worm, redflagzhulihua, *,
I stumbled again upon the issue and I can still not confirm your observation ...
:( On my system (Germanophone OOO320m17 under Debian SID AMD64) it works as
expected. Could you or doze_worm test it again under XP, please?
@doze_worm: As you has assigned your swf file to "text/rtf", I am not able to
watch this film in Firefox/Iceweasel 3.5.9. Interestingly my system will open it
in OOo ... :(
Comment 15 doze_worm 2010-05-10 03:19:28 UTC
I retest it again, and the problem remains in the OOo320m16 on WinXP.
Comment 16 doze_worm 2010-05-10 03:24:13 UTC
Created attachment 69384 [details]
submit again, correct the MIME type
Comment 17 doze_worm 2010-05-10 03:30:36 UTC
Created attachment 69385 [details]
Pleash omit the 2nd and the 3rd attachments
Comment 18 thackert 2010-08-29 10:58:21 UTC
Hello doze_worm, *,
I am not sure, what is wrong either with your attached files and/or my system
... :( I have downloaded the first one
at my disk, but if I open it in VLC, it is nearly one second long and black. The
second attachment
just opens a new tab with a black background in Firefox 4.0b4, but nothing
happens then ... :( But as I still have not the possibility to test it ... ;)