Issue 98386 - modify the select region in ImageMap crash OOo
Summary: modify the select region in ImageMap crash OOo
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOO300m9
Hardware: PC All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: wolframgarten
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks: 84405
  Show dependency tree
 
Reported: 2009-01-23 07:49 UTC by doze_worm
Modified: 2013-08-07 14:43 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description doze_worm 2009-01-23 07:49:54 UTC
[Steps]
1. Create a Writer doc.
2. "Insert" -> "Picture" -> "From File...", to insert a picture.
3. Select the picture, "Edit" -> "ImageMap", click "Rectangle" or "Ellipse"
button on the "ImageMap Editor" dialog-box, and draw a select range on the picture.
4. Modify the select region, such as resize and drag to move.

[Result]
Crash and quit

[Expectation]
Modify the select region successfully in ImageMap Editor.
Comment 1 thorsten.martens 2009-01-23 10:03:27 UTC
TM->ES: please have a look.
Comment 2 eric.savary 2009-01-23 14:24:25 UTC
Good catch!

@OD: crashes as described ONLY SINCE m39 (m37 and m38 are ok).
Comment 3 Oliver-Rainer Wittmann 2009-01-26 09:58:15 UTC
OD->AW: Please take over as discussed, Thx.
Comment 4 Armin Le Grand 2009-01-26 14:05:27 UTC
AW: Argh! You only need to look at class IMapUserData in imapwnd.hxx to see:
This was done WITHOUT thinking. It's all in one class which has a Clone-Operator
who copies the local SdrObject pointer. Only some lines below is the destructor
which DELETES that SdrObject. This could never have worked and is BROKEN by DESIGN.
I will replace the SdrObject* with a boost::shared_ptr. Implementing, testing...
Comment 5 Armin Le Grand 2009-01-26 14:07:42 UTC
AW: Okay, works as expected. Committed, done.
What an outstanding example of parts of our code quality. I really think about
using a 'svn blame' on this one on occasion...
Comment 6 Armin Le Grand 2009-01-26 14:08:16 UTC
AW: Setting to fixed.
Comment 7 Armin Le Grand 2009-01-30 11:05:51 UTC
AW->WG: Please verify as described.
Comment 8 wolframgarten 2009-01-30 13:01:18 UTC
Verified in CWS.
Comment 9 wolframgarten 2009-02-26 10:22:56 UTC
Tested in OOO310_m3. Closed.