Issue 98419 - Underline colour rendering fault when drawing created using UNO API
Summary: Underline colour rendering fault when drawing created using UNO API
Status: CLOSED DUPLICATE of issue 99892
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: DEV300m35
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: hdu@apache.org
QA Contact: issues@gsl
URL:
Keywords:
Depends on: 99842 103692
Blocks:
  Show dependency tree
 
Reported: 2009-01-23 20:23 UTC by martinwhitaker
Modified: 2009-09-07 10:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
UNO application demonstrating the fault (6.17 KB, text/plain)
2009-01-23 20:25 UTC, martinwhitaker
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description martinwhitaker 2009-01-23 20:23:52 UTC
Split from issue #96474 as requested.

The attached Java program is used to create a drawing containing a single text
object. The text object contains two paragraphs of underlined text. For the
first paragraph, the underline colour is set to red. For the second paragraph,
the underline colour is set to automatic, so should be black (the font colour).
However, when rendered on screen, the underline colour in the second paragraph
is also red.

If the text object is edited, the text is correctly rendered. On leaving the
edit box, the incorrect rendering returns.

If the drawing is saved to a file and then reloaded, the text is correctly rendered.

I believe this is a fault in the new drawing layer because:

a) The fault was not present in the DEV300m28 snapshot.
b) The fault does not appear in the edit box (which is still using the old VCL
drawing layer).

This fault was still present in the DEV300m37 snapshot.
Comment 1 martinwhitaker 2009-01-23 20:25:15 UTC
Created attachment 59637 [details]
UNO application demonstrating the fault
Comment 2 philipp.lohmann 2009-01-26 09:56:56 UTC
@aw: could you please have a look ?
Comment 3 Armin Le Grand 2009-02-05 15:09:07 UTC
AW: Setting target and accepting.
Comment 4 groucho266 2009-04-08 16:40:02 UTC
See issue 100694 for a similar problem and a bugdoc without Java.
Comment 5 Armin Le Grand 2009-05-05 18:01:14 UTC
AW->HDU: Please check if this is double and evtl. fixed with Your fix for the
missing underline rendering color. If not, please send back.
Comment 6 hdu@apache.org 2009-05-06 11:46:55 UTC
Most likely a duplicate to fixed issue 99842.
Comment 7 hdu@apache.org 2009-08-27 15:20:48 UTC
With issue 99842 fixed since DEV300_m52 things look good. The related issue 103692 is fixed in CWS vcl104.

*** This issue has been marked as a duplicate of 99892 ***
Comment 8 hdu@apache.org 2009-09-07 10:41:18 UTC
Closing resolved issue