Issue 98439 - Buttons can be pasted onto protected sheets
Summary: Buttons can be pasted onto protected sheets
Status: CLOSED DUPLICATE of issue 98440
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 3.0
Hardware: Unknown Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-24 21:45 UTC by jimavera
Modified: 2009-07-12 18:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jimavera 2009-01-24 21:45:33 UTC
I'm not sure whether or not this is a bug, but it is possible to paste
buttons onto protected sheets.  The cell contents can not be changed, however
(as expected).

DEMO PROCEDURE:
  1. Create a button on one sheet
     Here is how:
      View->Toolsbars->Form Controls (check on)
      Click DesignModeOnOff (the second one) to make Design Mode on.
      Click the PushButton icon.  Cursor changes to cross-hairs
      Use the mouse to draw a button outline on the sheet.
     
  2. Create a new sheet. 
  6. Tools->ProtectDocument->Sheet; enable protection (no password necessary)
Comment 1 rvojta 2009-01-25 21:41:21 UTC
.

*** This issue has been marked as a duplicate of 98440 ***
Comment 2 Mechtilde 2009-07-12 18:06:24 UTC
duplicate -> closed