Issue 98549 - RPT: SRB not working with DEV300M40
Summary: RPT: SRB not working with DEV300M40
Status: RESOLVED FIXED
Alias: None
Product: Base
Classification: Application
Component: ReportBuilder (show other issues)
Version: DEV300m39
Hardware: Unknown All
: P2 Trivial (vote)
Target Milestone: OOo 3.1
Assignee: kurt.zenker
QA Contact: issues@dba
URL:
Keywords:
: 99186 99306 (view as issue list)
Depends on:
Blocks:
 
Reported: 2009-01-28 09:02 UTC by r4zoli
Modified: 2009-02-24 13:49 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description r4zoli 2009-01-28 09:02:42 UTC
Installed DEV300m40 on winXP and opensuse 10.3 i688.
Added SRB 1.1.0.7381 from qa-upload ftp.
SRB not working on this build.
If I try to open existing report not opens. Error report msg: "The document
cannot be opened", as same with no SRB installed.
New reports cannot be created in design mode, and with wizard.
On linux, OOo stated from terminal the output I get:

r4zoli@lassu:~> /opt/ooo-dev3/program/soffice
com.sun.star.uno.RuntimeException:
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java:178)
        at $Proxy4.createInstanceWithArguments(Unknown Source)
        at
com.sun.star.wizards.reportbuilder.ReportBuilderImplementation.initialize(ReportBuilderImplementation.java:188)
        at
com.sun.star.wizards.reportbuilder.ReportBuilderImplementation.getFrame(ReportBuilderImplementation.java:304)
        at
com.sun.star.wizards.reportbuilder.ReportBuilderImplementation.getWizardParent(ReportBuilderImplementation.java:135)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java:665)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java:569)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java:127)
com.sun.star.uno.RuntimeException:
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java:178)
        at $Proxy4.createInstanceWithArguments(Unknown Source)
        at
com.sun.star.wizards.reportbuilder.ReportBuilderImplementation.initialize(ReportBuilderImplementation.java:188)
        at
com.sun.star.wizards.reportbuilder.ReportBuilderImplementation.getFrame(ReportBuilderImplementation.java:304)
        at
com.sun.star.wizards.reportbuilder.ReportBuilderImplementation.getWizardParent(ReportBuilderImplementation.java:135)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java:665)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java:569)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java:127)
Comment 1 Frank Schönheit 2009-01-28 09:09:27 UTC
fs->oj: Since 1.1.0.7381 was a CWS snapshot (fro  rptfix04, IIRC), I do not know
whether it is intended to work in a MWS build. If so, please fix :), if not,
please discard the issue. Thanks.
Comment 2 ocke.janssen 2009-01-28 10:16:14 UTC
The problem comes in with the renaming of ENABLE_REPORTDESIGN with
ENABLE_REPORTBUILDER .

Next time when replacing a variable please do it at all places. ;-)

You missed solenv/config/sdev300.ini. That means that all SRB version out there
doesn't work with a DEV300_m40.
Comment 3 rene 2009-01-28 10:24:21 UTC
oj: yep, forgot your config
Comment 4 marc.neumann 2009-02-03 13:38:15 UTC
verified in CWS rptfix04

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Frptfix04
Comment 5 Frank Schönheit 2009-02-12 08:41:42 UTC
copied fix to CWS dba31i, which has better chances to be integrated into m2, to
have the SRB working on the master as, again, as fast as possible.
Comment 6 marc.neumann 2009-02-16 12:00:58 UTC
*** Issue 99186 has been marked as a duplicate of this issue. ***
Comment 7 Frank Schönheit 2009-02-17 21:13:55 UTC
*** Issue 99306 has been marked as a duplicate of this issue. ***
Comment 8 Frank Schönheit 2009-02-23 09:32:42 UTC
re-opening.

The fix was part of solenv/config/sdev300.ini. Unfortunately, this file has been
renamed on the OOO310 branch, to sooo310.ini (sounds quite reasonable).

Not sure whether SVN did not warn about this upon integration, or whether
release engineering overlooked the warning.

Anyway, the bottom line is: The report builder does *still* not work in m2
builds. Grr.
Comment 9 Frank Schönheit 2009-02-23 09:34:14 UTC
fs->kz: See above: The fix for this issue was part of CWS dba31i, but it got
lost during integration. Could you please manually integrate it into m3 (which
you're responsible for, as far as I've been told)? Thanks a lot.
Comment 10 kurt.zenker 2009-02-24 13:49:29 UTC
fixed missing solenv/config/sdev300.ini patch as masterfix for ooo310m3