Issue 98773 - Can't specify fonts of Report
Summary: Can't specify fonts of Report
Status: CONFIRMED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 3.0
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 98762 (view as issue list)
Depends on:
Blocks:
 
Reported: 2009-02-03 08:36 UTC by khirano
Modified: 2013-01-29 21:47 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
bugdoc (89.37 KB, application/vnd.sun.xml.base)
2009-02-03 08:38 UTC, khirano
no flags Details
Report (Writer) in vertical writing (12.00 KB, application/vnd.oasis.opendocument.text)
2009-02-04 01:31 UTC, khirano
no flags Details
Report (Writer) in vertical writing (51.13 KB, image/jpeg)
2009-02-04 01:34 UTC, khirano
no flags Details
Fonts changed to MS Mincho (17.61 KB, application/vnd.oasis.opendocument.text)
2009-02-04 14:11 UTC, khirano
no flags Details
Report (Writer) with Latin characters (9.26 KB, application/vnd.oasis.opendocument.text)
2009-02-04 16:10 UTC, khirano
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description khirano 2009-02-03 08:36:58 UTC
Base's Report Wizard exports Japanese letters with unknown fonts.
This results in incorrect positioning of Japanese punctuation marks and Japanese
bracket and others in Writer with vertical writing.  And if you export it to
PDF, their positioning get worse.

I hope we can specify fonts in Report Wizard.
Comment 1 khirano 2009-02-03 08:38:04 UTC
Created attachment 59844 [details]
bugdoc
Comment 2 khirano 2009-02-03 08:40:08 UTC
*** Issue 98762 has been marked as a duplicate of this issue. ***
Comment 3 khirano 2009-02-04 01:31:56 UTC
Created attachment 59883 [details]
Report (Writer) in vertical writing
Comment 4 khirano 2009-02-04 01:34:04 UTC
Created attachment 59884 [details]
Report (Writer) in vertical writing
Comment 5 Frank Schönheit 2009-02-04 08:59:49 UTC
In all three cases which are illustrated in the attached image, the behavior
does not depend on Base or the reporting: Simply copy'n'pasting the text from
the table cell into a Writer document (whose page has been set up to use
"Right-to-left (vertical)" layout) gives the very same result.

However, if I understand you right, this is not a Writer problem, but due to
wrong formatting information at the text (what would be the correct font to set
in Writer? Just to see the difference.). And your request is to be able to
specify, in the report wizard, which fonts to use when creating the report. Is
this correct?
Comment 6 khirano 2009-02-04 14:06:15 UTC
Hi fs,

In the Writer doc can you move your cursor to Headers such as "構文" and "訳文"?
Then what do you see on the formatting toolbar?

I (Windows Vista and OOo3.0.1) can see "Tbl_Record_Header" and "PMinchoL"

Original Reporter (Windows XP and OOo3.0.0) said he could see
"Tbl_Record_Header" but the font name box was empty.

If I move my cursor to a record such as "å’²ã„ãŸ," then I see
"Tbl_Record_Content" and "PMinchoL"

Original Reporter said he could see "Tbl_Record_Content" but the font name box
was empty.

I have never heard of this font name "PMinchoL"

If I Select All the text on the Writer doc and change the font to "MS 明æœ" then
punctuations and others are set in right positions.

I will show you :)

Comment 7 khirano 2009-02-04 14:11:49 UTC
Created attachment 59918 [details]
Fonts changed to MS Mincho
Comment 8 khirano 2009-02-04 14:16:09 UTC
And yes, you are right.
My request is to be able to specify, in the report wizard, which fonts to use
when creating the report.
Thank you for well describing :)
Comment 9 khirano 2009-02-04 14:29:25 UTC
Hi Herbert Duerr san,

We need your help.

Do you know what "PMinchoL" is and why Base Report Wizard exports this font?

Comment 10 hdu@apache.org 2009-02-04 15:31:13 UTC
I am not aware of a font that is directly named PMinchoL. There is a font from Ricoh with the name HG-
MinchoL though.

The problem itself reminds me of issue 24362: When some fonts don't correctly support vertical alternate 
glyphs this problem happens. It should be considered a font bug. On the other hand it is possible to 
identify this situation and work around it. Either by the operating system's GDI or by each application that 
tries to use the font for vertical writing. I'd prefer the former alternative.
Comment 11 khirano 2009-02-04 16:10:12 UTC
Created attachment 59928 [details]
Report (Writer) with Latin characters
Comment 12 khirano 2009-02-04 16:16:51 UTC
Can you take a look at "syntax.odt" I have just attached?

You can see Tbl_Record_Header's font is Thorndale and Tbl_Record_Content's font
is Albany.

Now my question is "What decides the font?"
Comment 13 Frank Schönheit 2009-02-06 09:48:25 UTC
the fonts are specified in the templates which are used by the report wizard.
Look into your OOo 3.0 installation folder, there's a
"Basis\share\template\ja\wizard\report" folder, and therein, you find a lot of
text document templates. If you open them, you'll find the PMinchoL is already
specified in those templates.

In our words, to me it seems the templates are broken, and should be fixed.
Also, editing those templates manually, and correcting the fonts, could be a
workaround for you.