Issue 98805 - basic dialogs - command buttons are not displayed
Summary: basic dialogs - command buttons are not displayed
Status: CLOSED DUPLICATE of issue 87596
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 3.0.1
Hardware: Unknown Windows, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: thorsten.martens
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-03 17:25 UTC by Oliver Brinzing
Modified: 2009-02-18 08:19 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
dialog test demo (9.97 KB, application/vnd.sun.xml.writer)
2009-02-03 17:25 UTC, Oliver Brinzing
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Oliver Brinzing 2009-02-03 17:25:22 UTC
i noticed a problem using oo basic dialogs from oo 1.1.5 in oo 3.0.1
it seems, some command buttons are not displayed if one uses:

 oModel.PositionY = 150
 oModel.PositionX = 180

please have a look at the attachment

is this a bug ?
Comment 1 Oliver Brinzing 2009-02-03 17:25:57 UTC
Created attachment 59865 [details]
dialog test demo
Comment 2 bmarcelly 2009-02-04 09:17:22 UTC
I think it is a duplicate of Issue 87596.
Comment 3 Olaf Felka 2009-02-16 09:37:45 UTC
Adding cd and fs to CC for further discussion.
Comment 4 Olaf Felka 2009-02-16 15:14:39 UTC
considered as duplicate

*** This issue has been marked as a duplicate of 87596 ***
Comment 5 Frank Schönheit 2009-02-18 07:36:08 UTC
Symptom-wise, we seem to have two problems here:

One is that setting the Width/Height property of a dialog does result in values
other than the one you set. For instance, if you modify the macro in the bug doc
of this issue here as follows:
    MsgBox oModel.Width & "x" & oModel.Height
    oModel.Width = 273
    oModel.Height = 234
    MsgBox oModel.Width & "x" & oModel.Height
, then you'll see that after setting Width and Height to 273x234, the actual
values are 267x218, instead.

I think that this part - Width/Height not working correctly - is in fact a
duplicate of issue 87596.

However, the second problem here is that changing the *position* of the dialog
also changes the size:
    MsgBox oModel.Width & "x" & oModel.Height
    oModel.Width = 273
    oModel.Height = 234
    MsgBox oModel.Width & "x" & oModel.Height
    oModel.PositionY = 150
    oModel.PositionX = 180
    MsgBox oModel.Width & "x" & oModel.Height
The third MsgBox will display "261x186", i.e. changing PositionX and PositionY
also changed the size.

Both problems might be related. In fact, I strongly believe that we have a
problem with window decorations here: Changing any of the geometry properties
seems to result in setting width/height to the real values minus window
decoration. At least, this was the root cause for a similar issue we had with
design-time dialogs (in the dialog editor).
Comment 6 Frank Schönheit 2009-02-18 07:54:22 UTC
Reverting the fix for issue 84487 (that is, revision 216256 of
toolkit/source/controls/dialogcontrol.cxx) fixes this issue here as well as
issue 87956. However, this of course re-introduces issue 84487, which in turn
was a regression caused by the fix for issue 78648. Seems this whole dialog
positioning thingie is somewhat ... fragile :(

I will spend some time thinking about how to fix this.

Closing this issue here, as in fact it is a duplicate of issue 87596, since both
have the same root cause.
Comment 7 Frank Schönheit 2009-02-18 07:55:43 UTC
now really closing
Comment 8 carsten.driesner 2009-02-18 08:19:11 UTC
cd->fs: Thanks for your effort. From my own experiences, toolkit code is very
fragile and there are many hidden dependencies.