Issue 99028 - Japanese characters in path or filename cause failure to load document
Summary: Japanese characters in path or filename cause failure to load document
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 3.1.1
Hardware: Mac Mac OS X, all
: P2 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2009-02-09 01:23 UTC by arglborps
Modified: 2015-09-22 23:36 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Japanese1ざ.odt Test case (7.87 KB, application/vnd.oasis.opendocument.text)
2015-09-22 23:19 UTC, sroig2013
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description arglborps 2009-02-09 01:23:30 UTC
Whenever I try to open any document with either Japanese characters in the
filename or in the path to the file I get an error as below:

<filename> does not exist.

This error appears when doubleclicking a file in the Finder, as well as when
trying to open it via the "open" dialogue. Apparently OpenOffice on the Mac
cannot handle Unicode filenames/paths.
Comment 1 wojas 2009-09-20 03:07:43 UTC
This issue is still unconfirmed for some reason, but it makes using OpenOffice
very hard in an international environment. Right now I have to rename files into
pure ascii names in order to be able to open them. This problem still persists
in 3.1.0.

1) Create a file in another OSX application, for example in Finder with the name
2) Try to open this file in OpenOffice. The name will display correctly in the
file open dialog but you cannot open it.

Please change the status to CONFIRMED.
Comment 2 arglborps 2009-09-25 08:29:20 UTC
Newest versions of Open Office still have this bug (3.1.1). I'm using NeoOffice, because this issue makes 
OO basically unusable for me (and mostly all of the Japanese users as well)
Comment 3 foral 2009-10-12 14:34:00 UTC
is it same problem?
Comment 4 wojas 2009-10-12 14:43:38 UTC
Yes, is the same problem.
I suspect that OpenOffice is using some old 8-bit compatibility API for opening
filenames instead of the 16-bit Unicode API.
Comment 5 wojas 2010-08-08 15:52:40 UTC
This issue still occurs in OOo 3.2.1 on OSX (and most likely only on OSX).

I do no understand why the status is still unconfirmed, this is a major defect preventing a large part of the 
world from using OOo on OSX.
Comment 6 wojas 2010-08-08 17:27:27 UTC
I tried with a clean new user account and could not reproduce this problem. After tweaking all kinds of 
language settings, I found what triggered the problem. I used customized British English locale settings 
(under 'Formats' in 'Language & Text'). Setting this to Dutch made the problem go away. Making 
changes to the Dutch settings does not seem to trigger any problems, switching back to my British 
English locale settings reintroduces the problem.

I run a recent clean install of Snow Leopard. The same problem occurred on Leopard before the 
reinstall, so I assume the problem is caused by a corrupted file in my home directory, but I do not know 
which one. Since my home directory and settings have in use since Tiger and more people experience 
this problem, it might also be caused by  an old locale settings file that for some reason is incompatible 
with Leopard and Snow Leopard.

If others can confirm the problems go away by changing their locale settings, this bug can probably be 
closed. I also noticed that a tab completions issue in the zsh commandline shell went away after these 
changes, so OOo is not the only package affected by this bug.

I do not know whether OOo can force the file system charset in the code, this could prevent the 
problem from occurring and should not cause problems, since all OSX system use the same encoding as 
far as I know. On the other hand I'm not 100% sure this will not introduce others problems and the 
number of people affected seems small.
Comment 7 arglborps 2010-08-08 17:50:07 UTC
Interesting I have set my locale to en-gb (British English), and I issued the bug report. About the system 
charset of the filesystem: it's been Unicode from day 1, so that should be irrelevant. Will try different 
locales and see whether it fixes the issue.
Comment 8 arglborps 2010-10-06 06:31:55 UTC
I've tried 3.2.1 and the 3.3 beta and when using OS X in English and trying to open a file with Japanese in 
the file name the same error still crops up. This basically means Open Office is still unusable for Japanese. 
I can't believe this error still exists.

This should be a show stopper issue.
Comment 9 arglborps 2010-10-06 06:36:41 UTC

The issue above might have the same or a similar causes, but it's different.
I am talking about opening a file with a perfectly intact Japanese filename (not a filename garbling 
"mojibake" issue). You double click on the file or drag & drop it (or use the "open" dialogue") and OO 
comes up with an error insisting that the "file does not exist", and won't open the file.
Comment 10 arglborps 2011-01-18 04:06:07 UTC
Still exists in most current version 3.2.1 this is pathetic.
Comment 11 tatsuyanaraoka 2011-02-01 15:02:22 UTC
I tried to open a document with  Japanese characters in the filename ,but I didn't get any 
I could open the file by doubleclicking in the Finder, or  by via the "open" dialogue.
When I tested the file named “無題.txt” made by other OSX application, I could open it.
When I tested the file named “名称未設定.odt” in British English locale settings , I didn't get 
any problems.
Whether I set MacOSX's System Preferences - International -language to “English” or “日本語”, 
the result was same.
My Environments are ;
OOo3.3.0 MacOS(PPC) version (Build;9567) on MacOSX 10.5.8.
Comment 12 arglborps 2011-02-02 03:11:34 UTC
I'm on 10.6.6 currently.
Comment 13 Rob Weir 2013-07-30 02:15:34 UTC
Reset assignee on issues not touched by assignee in more than 2000 days.
Comment 14 sroig2013 2015-09-22 23:19:42 UTC
Created attachment 84942 [details]
Japanese1ざ.odt Test case
Comment 15 sroig2013 2015-09-22 23:36:50 UTC
Comment on attachment 84942 [details]
Japanese1ざ.odt Test case

Machine: Macbook Pro

OS: OS X Yosemite 10.10.5, 2.2 GHz Intel Core i7, 8 GB 1333 MHz DDR3, Intel HD Graphics 3000 512 MB

Test 1:

AOO Version: 3.1.1

1. The attached file contains a Unicode Japanese character
2. Opening the attached file with Open Office 3.1.1 causes document recovery window to appear

Test 2: 

AOO Version: 3.1.1

1. Tried to open 一丂七丄丅丆万丈三.odt
2. Open Office Document recovery window showed up

Test 3:

AOO Version: 3.3.0

1. The attached file contains a Unicode Japanese character.
2. Open with AOO 3.3.0
3. It will work fine.

Test 4:

AOO Version: 3.3.0

1. I renamed atteched file to "一丂七丄丅丆万丈三.odt"
2. Opened it again with AOO 3.3.0
3. It worked fine for me

Just like I was able to open these Japanese Filenames in AOO 3.3.0.  It seems to not work on earlier versions according to the comments above.

This could indicate it is an issue for versions of AOO earlier than 3.3.0