Issue 99047 - VISTA: Some signs in Formulas not shown in writer
Summary: VISTA: Some signs in Formulas not shown in writer
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 3.0
Hardware: PC Windows, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: nospam
QA Contact: issues@sw
URL:
Keywords:
: 84297 (view as issue list)
Depends on: 87901
Blocks:
  Show dependency tree
 
Reported: 2009-02-09 14:53 UTC by thio
Modified: 2017-05-20 11:41 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
I made a screenshot to show the issue, here a minus sign is missing an the doublearrows are wrong (15.39 KB, image/png)
2009-02-09 15:16 UTC, thio
no flags Details
Sample formula; problem is in active OLE mode AND metafile (10.90 KB, application/vnd.oasis.opendocument.text)
2009-02-23 18:21 UTC, michael.ruess
no flags Details
OpenSymbol 1.12 (174.57 KB, application/octet-stream)
2009-03-06 14:07 UTC, nospam
no flags Details
Version 1.21 of OpenSymbol Font with Hinting (174.21 KB, application/octet-stream)
2009-08-10 08:07 UTC, nospam
no flags Details
Screeshot of bad equal symbol rendering. OpenSymbol v 1.21 with subpixel rendering on. (4.20 KB, image/png)
2009-08-12 23:44 UTC, troodon
no flags Details
99047.odt rendered on DEV300m52 Mac platform (3.25 KB, image/png)
2009-08-13 09:40 UTC, nospam
no flags Details
Math document shown in the screenshot attached in desc20 (5.17 KB, application/vnd.oasis.opendocument.formula)
2009-08-13 17:08 UTC, troodon
no flags Details
Writer sample document with formulas (78.96 KB, application/vnd.oasis.opendocument.formula)
2009-08-13 17:10 UTC, troodon
no flags Details
Math testcase document from issue 85391 (8.92 KB, application/vnd.oasis.opendocument.formula)
2009-08-13 17:16 UTC, troodon
no flags Details
Mac Screenshot of testcase.odf (26.60 KB, image/png)
2009-08-13 17:22 UTC, nospam
no flags Details
Screeshot of bad box brackets rendering. OpenSymbol v 1.21 with subpixel rendering on, 105% zoom level. (14.42 KB, image/png)
2009-08-13 17:31 UTC, troodon
no flags Details
Screenshot of tescase from desc27. Windows XP SP2, 1024x768, subpixel rendering on, zoom level 70% (7.98 KB, image/png)
2009-08-13 23:36 UTC, troodon
no flags Details
Screenshot of tescase from desc27. Windows XP SP2, 1024x768, subpixel rendering off, zoom level 70% (4.09 KB, image/png)
2009-08-13 23:36 UTC, troodon
no flags Details
Screenshot of tescase from desc27. OpenSymbol 1.21, Windows XP SP2, 1024x768, subpixel rendering off, zoom level 70% (7.71 KB, image/png)
2009-08-14 01:12 UTC, troodon
no flags Details
Another good test document (147.02 KB, application/vnd.oasis.opendocument.text)
2009-08-14 09:21 UTC, michael.ruess
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description thio 2009-02-09 14:53:34 UTC
It happens, that when i insert a Formula into a textfile, that certain signs in
the formula are not shown, or shown incorrectly. mainly this happened with
vector arrows, and minus signs in a x^{-y} like expression.

If i export the file as pdf or print it the signs are correct.
Comment 1 thio 2009-02-09 15:16:23 UTC
Created attachment 60047 [details]
I made a screenshot to show the issue, here a minus sign is missing an the doublearrows are wrong
Comment 2 michael.ruess 2009-02-09 19:30:11 UTC
I cannot reproduce this on WinXP. Maybe you have an older "OpenSymbol" font on
your system from a previous OO 2.x installation? Current version is 1.11, please
check - for this version the display of "equal" and "minus" signs has been
improved...
Comment 3 thio 2009-02-09 19:48:22 UTC
I checked it, the version of the opensymbol font in windows font folder is 1.11.
Comment 4 michael.ruess 2009-02-23 18:20:19 UTC
MRU->HDU: could you please have a look? I will attach a sample formula, where
the described problems will be shown. E.g. in a 2^-t the minus is not displayed
or only one line of a double line arrow. This happens only under Win Vista.
Comment 5 michael.ruess 2009-02-23 18:21:25 UTC
Created attachment 60399 [details]
Sample formula; problem is in active OLE mode AND metafile
Comment 6 hdu@apache.org 2009-02-27 11:53:13 UTC
@ih: this problem is exactly the same problem as in issue 82685 (and indirectly issue 87901) which are both 
supposed to be fixed with OpenSymbol 1.11. The problem still happens with exactly that version of OpenSymbol 
though, so I guess OpenSymbol needs to be reworked again. As the minus sign is just a rectangle adding the hints 
should be rather trivial for any reasonable font-editor.
Comment 7 nospam 2009-03-06 14:05:36 UTC
starting to create TT-Hints for the font...
Comment 8 nospam 2009-03-06 14:07:56 UTC
Created attachment 60785 [details]
OpenSymbol 1.12
Comment 9 nospam 2009-03-06 14:09:12 UTC
please check Version 1.12 of the font - but this is just a first release with
hinting - more will follow
Comment 10 nospam 2009-03-09 14:58:43 UTC
*** Issue 84297 has been marked as a duplicate of this issue. ***
Comment 11 nospam 2009-03-09 15:01:48 UTC
due to some tests, set to Windows all

problems will be fixed by adding TT-Hinting to the font (outline base will be 1.11 without extra thick 
strokes for = and - and some other chars...) so we get better results after all


Comment 12 nospam 2009-08-10 08:04:30 UTC
@all: please test the attached OpenSymbol Font (with Hinting) on VISTA! Does it fix our problems?
Comment 13 nospam 2009-08-10 08:07:15 UTC
Created attachment 64032 [details]
Version 1.21 of OpenSymbol Font with Hinting
Comment 14 nospam 2009-08-12 16:07:45 UTC
@all: Anybody out there for testing this on VISTA?
Comment 15 ooo 2009-08-12 16:41:56 UTC
I will take a look...
Comment 16 michael.ruess 2009-08-12 17:28:38 UTC
I already had a look on it with my Vista Notebook. Looks good until now.
Is it also of interest to test this on Win 7? I could do that on my Home-PC
where I have inatalled the Win 7 RC.
Comment 17 nospam 2009-08-12 20:03:33 UTC
Windows 7 might be interesting:
We should check this on as much platforms as possible, because I want to put this new version of 
OpenSymbol (1.21- with hinting) into the OOo 3.2 release. Some bugs are duplicate to this and all have to 
do with the disappearing of tiny parts of some symbols - so hinting should fix them all.

On Mac the new font is OK, even on 45% Zoom-Rate.

Comment 18 troodon 2009-08-12 23:42:44 UTC
->ih

1.21 looks great but it still shows the "asymetric" equal symbol rendering at
some zoom levels. I mean when the upper or the lower bar of the equal symbol is
rendered as thicker than the other one - see the attached screenshot.

In Math, I see the problem at zoom levels between 147% and 165% with the default
font settings. 1280x800, Windows Vista SP1, subpixel rendering on.
Comment 19 troodon 2009-08-12 23:44:34 UTC
Created attachment 64104 [details]
Screeshot of bad equal symbol rendering. OpenSymbol v 1.21 with subpixel rendering on.
Comment 20 troodon 2009-08-13 00:09:00 UTC
Another issue: the lower part of the gamma symbol (%gamma) is missing at zoom
levels >115% in the same conditions as specified in desc19. You can see that too
in the screenshot I attached. This issue was also present in previous versions
of the font (and least in 1.10 and 1.11).
Comment 21 nospam 2009-08-13 09:34:36 UTC
On the Mac Platform both parts of the equal sign are rendered in the same size - I think it no such big 
problem if on some platforms the parts have different sizes. I is only a problem if one part completely 
disappears. 
The "disappearing lower part"-problem of the gamma symbol can not be fixed in the font itself it is 
due to the rendering in writer or/and formula editor.

This new version of the font with Hinting does fix a lot of our disappearing problems and so I think we 
should put this version into OOo3.2  - It is of course better than the old one

@troodon: can you please attach the document of your sample formula
Comment 22 nospam 2009-08-13 09:39:27 UTC
It looks like there are some other fixes in Office that improve the quality of the rendering. I have attached 
a screenshot of 99047.odt made on Mac with DEV300m52.
Comment 23 nospam 2009-08-13 09:40:30 UTC
Created attachment 64107 [details]
99047.odt rendered on DEV300m52 Mac platform
Comment 24 troodon 2009-08-13 17:08:08 UTC
Created attachment 64140 [details]
Math document shown in the screenshot attached in desc20
Comment 25 troodon 2009-08-13 17:10:26 UTC
Created attachment 64141 [details]
Writer sample document with formulas
Comment 26 troodon 2009-08-13 17:16:06 UTC
Created attachment 64142 [details]
Math testcase document from issue 85391
Comment 27 nospam 2009-08-13 17:20:38 UTC
troodon's test document looks good on my mac (see my attachment)
Comment 28 nospam 2009-08-13 17:22:12 UTC
Created attachment 64143 [details]
Mac Screenshot of testcase.odf
Comment 29 troodon 2009-08-13 17:31:30 UTC
Created attachment 64144 [details]
Screeshot of bad box brackets rendering. OpenSymbol v 1.21 with subpixel rendering on, 105% zoom level.
Comment 30 troodon 2009-08-13 17:33:23 UTC
->ih

In desc25 I've attached the Math document showed in desc20. In desc26 I've
attached a Writer document with many formulas you can test with too.

In desc27 I've attached the same Math document as in issue 85391 and I've done
so because at zoom levels between 105% and 114% and around 85% to upper part of
the box backets is not shown, as you can see in the screeshot from desc30.

1280x800, Windows Vista SP1, subpixel rendering on.
Comment 31 troodon 2009-08-13 17:38:01 UTC
If forgot to add that the documents from desc26 and desc27 use the DejaVu Serif
font for text.

Also, if you compare the screenshot from desc30 with the one from issue 85931,
you can see the symbol rendering has improved a lot!
Comment 32 nospam 2009-08-13 18:15:07 UTC
@troodon: so if you also think that the quality of the font has improved a lot - do I have your OK to put 
this version into OOo3.2? I think the initial problem of this bug is fixed. 
If we have additional problems we should file new bugs.
I want to use this bug and it's dependencies to check in Version 1.21 of the font. 
Some of the new problems that have come up here can not be fixed in the font itself.

@all: is it OK for all of you, that I set this bug to fixed and check in the new font?

Comment 33 troodon 2009-08-13 23:34:24 UTC
->ih

Not so fast! :-) Tested the document from desc27 with OpenSymbol 1.21 in Windows
XP SP2 (1024x768) and the results are not so good: at 70% zoom level + is
rendered as | and = is renderes as  -. See the attached screenshots

Should I open new issues for the gamma and the box brackets problem?
Comment 34 troodon 2009-08-13 23:36:24 UTC
Created attachment 64145 [details]
Screenshot of tescase from desc27. Windows XP SP2, 1024x768, subpixel rendering on, zoom level 70%
Comment 35 troodon 2009-08-13 23:36:53 UTC
Created attachment 64146 [details]
Screenshot of tescase from desc27. Windows XP SP2, 1024x768, subpixel rendering off, zoom level 70%
Comment 36 troodon 2009-08-14 01:10:37 UTC
->ih

Plase ignore what I said in desc34 about Windows XP because the font wasn't
properly updated and the screenshots show an older version.

Now you have my ok ;-)! Even if there are some little problems, v 1.21 is much
better than older versions.
Comment 37 troodon 2009-08-14 01:12:00 UTC
Created attachment 64148 [details]
Screenshot of tescase from desc27. OpenSymbol 1.21, Windows XP SP2, 1024x768, subpixel rendering off, zoom level 70%
Comment 38 michael.ruess 2009-08-14 09:20:25 UTC
MRU->troodon: what you described in desc34 ("at 70% zoom level + is
rendered as | and = is renderes as  -") - are these regressions to openSymbol 1.11?
From my Point of view I cannot complain about the quality of OpenSymbol 1.21 (an
indeen, it is my job to complain ;-) ).
Comment 39 michael.ruess 2009-08-14 09:21:25 UTC
Created attachment 64155 [details]
Another good test document
Comment 40 weko 2009-08-14 09:35:10 UTC
@mru: Thanks for the great test document. It looks okay on WinXP SP3.

@all: To make a long story short: It is time to mark this issue as "fixed".

@ih: Please proceed.
Comment 41 nospam 2009-08-14 09:45:06 UTC
@mru: troodon said in his last comment that he had regressions 

the new testdoc also looks ok on Mac - we never had such a great qualitiy of the font and a lot of all our 
old problems about disappearing parts of some glyphs are fixed

so everybody is satisfied and I set this to fixed - the new version will make it's way into OOo3.2 in CWS 
Extras320

@troodon: please file bugs for the other last minor problems
Comment 42 michael.ruess 2009-08-14 13:27:09 UTC
I have checked v1.21 now on WinVista, Win7 and Ubuntu 64bit. I agree with all of
you that this is definitely the best OpenSymbol font we ever had.
Comment 43 troodon 2009-08-14 20:15:00 UTC
->mru

See desc37 :-)

->ih

I've filled issue 104239 (gamma issue) and 104240 (brackets issue). Should I
fill another one for the "small" problem (desc22) of one bar of the equal sign
being rendered as thicker as the other one (desc19 and desc20) or is a "wontfix"
case?

Thank you for your great work!
Comment 44 nospam 2009-08-17 08:13:32 UTC
->troodon: thanks for your help - please file another issue for the problem with the bars of the euqual 
sign
Comment 45 troodon 2009-08-17 22:14:45 UTC
->ih

Filled issue 104299 for the equal sign bars problem. Thank you!
Comment 46 weko 2009-08-20 10:28:17 UTC
Verified in CWS extras320.