Issue 99075 - Formula not recalculated
Summary: Formula not recalculated
Status: CLOSED DUPLICATE of issue 79854
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOO300m9
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2009-02-10 13:49 UTC by askerix
Modified: 2009-02-11 12:30 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description askerix 2009-02-10 13:49:24 UTC
I created a spreadsheet which should recognize the application that opened it.
Opening the spreadsheet in MS Excel, the cell is correctly recalculated, while 
it fails in O.O. Calc. I tried also to force recalculation manually, by 
pressing F9 or editing the cell without modifiy its content. It works only if I 
modify the cell's content.
It happens when you first open the spreadsheet with MS Excel then with Calc.
The formula typed in the cell is the following:
(italian version)
=SE(VAL.ERRORE(ADESSO()+ATTUALE());"MSExcel";"OpenOfficeCalc")
(english version)
=IF(ISERROR(NOW()+CURRENT());"MSExcel";"OpenOfficeCalc")

Best regards.
Alessandro
Comment 1 Regina Henschel 2009-02-10 22:34:30 UTC
The problem is, that the CURRENT function gets a MARCRO?-remark, because it
doesn't exist in Excel.

You need no Excel to force this behavior, but save the file to xls-format, close
it and reopen it in OOo. It is OOo itself, that sets the macro remark. Similar
issues 86073 and 91072 had been closed as "invalid". But perhaps that should be
rethought. OOo should export such functions as if they would exist in Excel and
leave it to Excel to mark them as unknown.

Issue 79854 covers the wish to chance the current behavior. Therefore I set this
issue to duplicate.

*** This issue has been marked as a duplicate of 79854 ***
Comment 2 Regina Henschel 2009-02-11 12:30:15 UTC
closing duplicate