Issue 99167 - Crash with file dialog after a toolbar is removed
Summary: Crash with file dialog after a toolbar is removed
Status: CLOSED FIXED
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: current
Hardware: All Windows, all
: P2 Trivial (vote)
Target Milestone: OOo 3.1
Assignee: stefan.baltzer
QA Contact: issues@gsl
URL:
Keywords: regression
: 99312 (view as issue list)
Depends on:
Blocks: 95768
  Show dependency tree
 
Reported: 2009-02-12 18:28 UTC by niklas.nebel
Modified: 2009-04-02 04:41 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description niklas.nebel 2009-02-12 18:28:01 UTC
In OOO310m1: Create a new Writer document, insert a table, see the table toolbar.
Move the cursor out of the table, see the table toolbar disappear.
Now select File/Open. Office crashes.

Looks related to the fix for issue 93173.
Comment 1 stefan.baltzer 2009-02-13 10:49:43 UTC
Put myself on CC.
Comment 2 philipp.lohmann 2009-02-16 15:19:59 UTC
since reverting the change for issue 93173 does not change the crash, I think
that relation does not really exist.
Comment 3 philipp.lohmann 2009-02-16 15:32:03 UTC
Hmpf, of course my last statement was wrong, reverting said change indeed does
solve the problem.
Comment 4 philipp.lohmann 2009-02-16 16:02:23 UTC
Seems to work with other torn off toolbars as well. Weirder still, the crash
does not occur if you use the OOo file dialog.

It seems I'm too daft to find the connection here why deleting the toolbars
lazily causes problems; for 3.1 at least the assertion is better than a crash,
so I'll revert the change for issue 93173. Will reopen that one.

Fixed in CWS ooo31gsl2
Comment 5 michael.ruess 2009-02-18 09:44:13 UTC
*** Issue 99312 has been marked as a duplicate of this issue. ***
Comment 6 philipp.lohmann 2009-02-19 09:54:25 UTC
please verify in CWS ooo31gsl2
Comment 7 stefan.baltzer 2009-02-20 14:40:04 UTC
Verified in CWS ooo31gsl2.
Comment 8 vladimir_hitekschool 2009-03-31 08:35:20 UTC
Issue 99167 has been fixed in master version OOo-dev 3.1 .0 (OOO310m7 Build:9393) 
for Windows XP and can be closed.
Comment 9 oleghitekschool 2009-04-01 04:49:48 UTC
Checked by HitekSchool Group 1 interns within Bug Hunting Party. Fixed.
Comment 10 nataliamhitekschool 2009-04-01 06:59:59 UTC
Verified in OOO310m7 master version on Windows Vista - Fixed. Can be closed
Comment 11 nataliamhitekschool 2009-04-01 07:58:32 UTC
Verified in OOO310m7 master version on Windows Vista - Fixed. Can be closed.
Comment 12 oleghitekschool 2009-04-02 04:41:56 UTC
Natalia, thank you, it has been closed already - see above.