Issue 99195 - cut and paste looses sections when selection ends with section
Summary: cut and paste looses sections when selection ends with section
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOO300m9
Hardware: Unknown All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-13 10:37 UTC by borsotti
Modified: 2017-05-20 11:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description borsotti 2009-02-13 10:37:25 UTC
Open a new document, type a line of text (e.g. "foo"), then on a new line insert
a section. Put the cursor at the beginning of the section and introduce a line
(e.g. "bar"). The document looks like:

foo
----------------
bar
----------------

Then click the mouse before "foo" and drag it right after "bar" (i.e. after the
"r", and not on the line below.
Then cut the selected text, and paste it in the same place.
The section has disappeared.

I have tested it in release 3.0.1 on Vista.

-Angelo Borsotti
Comment 1 michael.ruess 2009-02-13 11:03:19 UTC
MRU->OD: I know, the selection must end one paragraph beyond a section to copy
it to clipboard. But in such a case as the mentioned, it should also work.
Comment 2 Marcus 2017-05-20 11:22:47 UTC
Reset assigne to the default "issues@openoffice.apache.org".