Issue 99333 - Duplicate entries in Tool Customize Shortcuts for Writer
Summary: Duplicate entries in Tool Customize Shortcuts for Writer
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOO310m1
Hardware: Unknown All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 104958 (view as issue list)
Depends on: 99468
Blocks:
  Show dependency tree
 
Reported: 2009-02-17 19:06 UTC by sgautier.ooo
Modified: 2017-05-20 11:17 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description sgautier.ooo 2009-02-17 19:06:06 UTC
Hi, 

There is several duplicate entries in the function list of Tools > Customize >
Shortcuts in Writer. I can't locate the strings in the sdf file to give you the ID.
Edit > Backspace appears 2 times
Edit > Fields appears 2 times
Edit > Links appears 2 times
Insert > Formula appears 2 times
Format > Bottom appears 2 times
Format > Center appears 2 times
Format > Centered appears 3 times
Format > Font color appears 2 times
Format > Justified appears 2 times
Format > Left 2 appears times
Format > Top 2 times

Kind regards
Sophie
Comment 1 eric.savary 2009-02-17 19:27:43 UTC
@sophie: Thanx for tracking this! But may I warn you? ;)
I used to track all those duplicates in Writer, all not working entries, all
wrong labeled entries, all entries which don't work as they anounce and so on!

The problem is (are):
- Those entries are owned by the developer of each corresponding function.
So in theory, one should write 1 issue per entry!
- tracking those entries results in the end in P4-P5 issues set to later because
"there are bigger fishes to catch"...

Now I never report such bugs unless they result of a new feature I am working on.

Just want to say: don't waste *your* precious time! ;)
Comment 2 sgautier.ooo 2009-02-17 19:42:53 UTC
@Éric: thanks a lot for your comment :) I'm aware of the owning of the entries
(may be this is why they are distributed in all files but in officecg ;) But
some FR members are complaining about those duplicates, so at least, I open this
issue...
Comment 3 Regina Henschel 2009-02-17 20:13:58 UTC
Those entries are not duplicate. You can see the difference, when you look at
the same entries for symbols. For example one 'field' is .uno:UpdateFields
'Updates the contents of all fields in the document' and the other is
.uno:FieldDialog 'Opens a dialog where you can edit the properties...' The real
problem is, that the keyboard part neither tells the command nor the
description, but that is already issue 40747.
Comment 4 eric.savary 2009-02-17 20:47:43 UTC
@Regina: I do agree and not! ;)
While those entries are *internally* not duplicate, their labels are and the
result is a bad user experience (which entry does what I want? What does it do?)

But thanx for pointing at issue 40747!
I voted for it hopping, one day...

@MBA:
- do we want to close this issue duplicate of issue 40747?
- wouldn't it be better to reassign issue 40747 to requirements while I know CJ
doesn't work on this area anymore? ;)
Comment 5 sgautier.ooo 2009-02-17 21:03:53 UTC
@Regina: thanks for pointing the duplicates issue. I agree that this is not
duplicates entries most of the time, but for ux this is the same result. More
you have an hard time to know what shortcuts really do playing with them.

@Éric: I don't think this issue should be closed as duplicate of 40747 because
it deals only with the formula shortcuts. 
This present issue could be a referrer to all the other ones that should be open.

@mba, es: I see that mmp was on the 40747, may be we could put those dups in ux
hands and ask about their help? I'll write an mail on the list tomorrow to get
their attention
Comment 6 Uwe Fischer 2009-02-20 11:41:12 UTC
IMHO the Customize Keyboard tab page should be redesigned. At least it should
show the "Description" string as the other two tab pages for Menus and Toolbars do.
The Description strings always show an extended help text that is assigned to
that command (that means to the relevant .uno:help-id)
However, as Eric stated, it is not always very easy to find out what the command
does, who is the dev owner, and what the relevant help text should be. 
Comment 7 eric.savary 2009-02-20 16:57:20 UTC
I do fully agree with UFI who agrees with me! ;)))

But, indeed, we may try to fix (in this case, I'd say "hack") those problems by
correcting the strings.

To allow a fix I let this issue open and I files issue 99468 for the global problem.

!!! IMPORTANT !!!!!

Please, WHOEVER FIXES THIS: have a look at my comments at
http://www.openoffice.org/issues/show_bug.cgi?id=40747desc25

*Don't correct the strings only looking at the Customize dialog but for each
function you correct, have a look at it its UI context (menu, dialog...) and
find a string that may suite to both contexts*!!!  
Comment 8 eric.savary 2009-02-22 14:35:39 UTC
Let's detail all findings for possible issue splitting or fix advices:

1) Edit > Backspace appears 2 times

a) both have empty descriptions under Toolbars
b) the second "Backspace" seems to be useless for it does the same as the 1st
one and its shortcut is Shift+Backspace which is not known to be a standard
shortcut.

Proposal: remove the 2d entry

2) Edit > Fields appears 2 times

a) The 1st entry should not be under "Edit" but under "Options" (which itself
should be called "Tools", see issue 99468) because it does "Tools - Update -
Fields F9"
b) As long as issue 99468 is not fixed, we cannot change those strings because:
Changing "Fields" to "Update Fields" would chamge the corresponding menu to
"Tools - Update - Update Fields" which doesn't in the menu context

Proposal: wait for Meta issue 99468 to be fixed.

3) Edit > Links appears 2 times
Exactly the same problem as 2):
a) First entry at wrong place
b) Can't rename without messing menu

Proposal: wait for Meta issue 99468 to be fixed.

4) Insert > Formula appears 2 times
Guessing this will be addressed with issue 40747 unless it is only fixed for
Calc. In this case, use the same fix as Calc.

Proposal: wait for Meta issue 40747 to be fixed.

5) Format > Bottom appears 2 times

a) The first entry apparently refers to "Format - Frame - Typ - Position -
Vertical: Bottom". It has an empty description under Toolbars.
It seem to be duplicate of Category "Frame", Function "Align Bottom"

b) The 2nd entry refers to the alignment of Draw objects to each other.

c) Amazing is that this 2nd entry is enable even if a Writer frame is
selected... But that's another bug. A functionality bug.

Proposal:
a) Remove the first entry
b) Move the 2nd entry from "Format" to "Drawing"
c) Don't change any string! Would probably create a mess in the dialogs!

6) Format > Center appears 2 times

Same as 5) but there the 1st entry refers to Draw while the 2d to Frames
Same proposals.

7) Format > Centered appears 3 times

Same as 5) but:
- the 1st entry applies to Frames (remove it as dup in "Frame")
- the 2nd entry applies to Paragraphs
- the 3rd entry applies to Draw objects

Same proposals.

8) Format > Font color appears 2 times

Both functions have basically the same use, differences:
- 2nd entry also allows to call the character dialog
- 1st entry seems to be the "Font color" icon from the standard Formatting toolbar

Proposal: remove 2nd string if not needed. It's a real duplicate.

9) Format > Justified appears 2 times

Basically the same as 5) but:
- the 1st entry applies to Paragraphs
- the 2nd entry applies to Draw objects

Proposal: move 2nd entry to category "Drawing"

10) Format > Left 2 appears times

Basically the same as 5):
- the 1st entry applies to Paragraphs
- the 2nd entry applies to Draw objects

Proposal: move 2nd entry to category "Drawing"

11) Format > Top 2 times

Same as 5) but:
- the 1st entry applies to Draw objects
- the 2nd entry applies to Frames (remove it as dup in "Frame")

Proposal:
- move 2nd entry to category "Drawing"
- remove the 1st entry as dup in "Frame"


I hope this analyze makes clear to anyone reads this how the "duplicate entries"
problematic seems trivial to fix ("simply rename them") but IS NOT!
It is complicated, resource hungry, risky and in the end is not a huge leverage
in the user experience (how often does a user configures toolbars and shortcuts
every day?)

Hoping that the meta issue 99468 will help making such small issues easier to
fix in the future.
Comment 9 Uwe Fischer 2009-02-23 09:00:00 UTC
It's cumbersome and needs some time to fix these strings. They are bound to the
Help ID. Everyone who wants to look at the Help IDs, for example in the
Description text of the Menu or Toolbar tab page, can add the following
environment variable before starting the office: 
set the variable HELP_DEBUG to any value. Then press Shift+F1 or enable extended
help tips.
Comment 10 sgautier.ooo 2009-02-23 12:53:04 UTC
Hi Ufi, 
So, 
1) Edit > Backspace
a) swriter - 33306
b) swriter - 33306
Is it what you need? Kind regards - Sophie
Comment 11 Uwe Fischer 2009-02-23 13:22:25 UTC
@Sophie: My remark was intended to give some information to everyone who might
be curious about why there are double entries in the Customize dialog. 
More information follows: When a Help ID and respective help text is already
present in any *.xhp help source file, you see that help text in the Description
field of the Customize - Toolbars or Customize - Menus dialog.
If no help text is assigned, the Description field normally stays empty. With
the environment variable HELP_DEBUG set, the Description field is not totally
empty, but the Help ID is shown.
Now, to get descriptive text for all commands that you can customize, we would
need to insert the Help IDs and a descriptive text somewhere into the help
source files.
The main problem that I see at this time: By definition the Help IDs without
text are unknown to us. So we must find out what the corresponding commands are,
where they can be found, in which module, in which context. And there is no list
of Help IDs versus responsible developer. 
We could search all source files for the .uno: Help IDs and try to guess who is
the developer in charge, then ask the developer. For the numeric Help IDs we
first must look them up in the hid.lst file that is part of every CWS, note the
respective long text format of the Help ID, then look for that in the source files.
Or we can publish a list of "unknown" but used Help IDs and ask everyone to add
 some pointers.  
Or we can guess what command it is by experimentation and make up a matching
help text from that.
Comment 12 sgautier.ooo 2009-02-23 15:39:41 UTC
@Ufi: thanks for your explanations, that shows well the complexity of the fixes...
Comment 13 michael.ruess 2009-09-14 13:14:32 UTC
*** Issue 104958 has been marked as a duplicate of this issue. ***
Comment 14 meywer 2009-09-14 21:21:12 UTC
would like to vote for this, but can't (see issue 69811)
Comment 15 Marcus 2017-05-20 11:17:50 UTC
Reset assigne to the default "issues@openoffice.apache.org".