Issue 99344 - cannot save files
Summary: cannot save files
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 3.0
Hardware: PC Windows Vista
: P2 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: thorsten.martens
QA Contact: issues@framework
URL:
Keywords: needmoreinfo, oooqa
Depends on:
Blocks:
 
Reported: 2009-02-17 21:51 UTC by wkussmaul
Modified: 2010-10-17 08:03 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
screenshot 1 / 4 (102.71 KB, image/png)
2009-03-24 19:43 UTC, aiamama
no flags Details
screenshot 2 / 4 attempting to save the file (98.19 KB, image/png)
2009-03-24 19:44 UTC, aiamama
no flags Details
screenshot 3 / 4 please note that lock file has disappeared. (98.55 KB, image/png)
2009-03-24 19:46 UTC, aiamama
no flags Details
screenshot 4 / 4 the lock file keeps disappearing (97.51 KB, image/png)
2009-03-24 19:47 UTC, aiamama
no flags Details
the files at the screenshot with english file names too (427.70 KB, application/octet-stream)
2009-03-24 19:56 UTC, aiamama
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description wkussmaul 2009-02-17 21:51:23 UTC
Both writer and calc get into a state where they can only save files in the MS
Office 97 format and not in ODF format. When I attempt to save a file named
setting_up_virtual_hosts.odt I get the following big-red-X error message: 

"Error saving the document setting_up_virtual_hosts.odt. 
Error writing file."

When I attempt to save under a different name the I get the same error message,
only with the original file name.

When I attempt to save a file that I have opened (having been saved earlier) I
get the message that the file already exists; would I like to replace it? I
respond in the affirmative and subsequently get the original can't-save error
message.

*Yet when I then change the extension to .doc, it saves just fine!*

Is this being done by Vista? If so it is a very serious restraint-of-trade legal
issue.
Comment 1 Rainer Bielefeld 2009-02-18 06:09:51 UTC
I never saw that with "Ooo 3.0.0 (DE) Multilingual version German UI WIN XP:
[OOO300m9 (Build9358)]", seems to be VISTA specific.

@wkussmaul:
Can you please try 3.0.1.?
Comment 2 aiamama 2009-03-24 19:37:57 UTC
I am using OOo3.0 Korean language version in Windows XP

I was encountered the error message translating to English..

"writing error: error while saving the _documentName_ "
"could not write the file."

I made some screenshots.
and note that the LOCK file has been disappeared from the folder of 
document location, while attempting to save the document.

If I retry to save the file, for about 2 seconds of time, the LOCK file 
appears but with the error message, it disappears again.

I made some new ODS file in the same folder, it saves well.
so, I think that it is not related to file permission problem.

Comment 3 aiamama 2009-03-24 19:43:19 UTC
생성된 첨부 파일 (id=61152)
screenshot 1 / 4
Comment 4 aiamama 2009-03-24 19:44:37 UTC
생성된 첨부 파일 (id=61153)
screenshot 2 / 4 attempting to save the file
Comment 5 aiamama 2009-03-24 19:46:10 UTC
생성된 첨부 파일 (id=61154)
screenshot 3 / 4 please note that lock file has disappeared.
Comment 6 aiamama 2009-03-24 19:47:21 UTC
생성된 첨부 파일 (id=61155)
screenshot 4 / 4 the lock file keeps disappearing
Comment 7 aiamama 2009-03-24 19:56:42 UTC
생성된 첨부 파일 (id=61156)
the files at the screenshot with english file names too
Comment 8 wkussmaul 2009-03-24 21:10:35 UTC
rainerbielefeld:

I have upgraded to 3.0.1 and I still have the problem. 

If I close the .doc version, then reopen it, I can then save as .odt, and I
notice that the lock file changes its extension appropriately.
Comment 9 Olaf Felka 2009-05-22 07:15:56 UTC
We haven't been able to reproduce. Would you like to try it again with OOo 3.1?
We have changed a lot for file locking.
Comment 10 wkussmaul 2009-05-22 15:37:20 UTC
I have installed OO 3.1. However, the condition occurs intermittently so I can't
tell whether 3.1 fixes it or not.

wk
Comment 11 kanupriya 2009-09-14 16:27:40 UTC
Issue : cannot save files

Reproduced: Not repeatable (Seems FIXED)

Configuration Used : 

     OS                 ->    Windows Vista
     RAM Used           ->    4 GB  


Build Used:     OpenOffice Version 3.3.1


Steps Followed:

  1. Open a new document and add few content in the file.
  2. Save as it in the file type of *.odt.
  3. Attempt to save the same file in the file type of *.doc.
  4. I was able to reproduce the issue if the same file I was trying to save is 
     also opened in another Openoffice.
  5. But this is the expected behavior.
   
  
Comments:

   1> I noticed that all the issues being reported where on the non-english 
platform but 
      I was using English platform.

   2> Issue seems to be fixed.
Comment 12 lohmaier 2010-03-25 21:37:57 UTC
Hmm - not sure about the sample-zip. The issue talks about odt files, and saving 
them as doc, but the attachment contains spreadsheet?

Anyway: 
As this is not reproducible by any qa-volunteer, I guess it is duplicate to 
issue 94415 where special characters in the user-name caused a wrong parsing of 
the lockfile.

Could you please check whether it still occurs in a current version?

And if so, could you attach the lockfile?
Comment 13 Olaf Felka 2010-10-12 15:38:35 UTC
It has not been reproducible for all testers here. No further answer on the last
question: Works for me.
Comment 14 Mechtilde 2010-10-17 08:03:23 UTC
worksforme -> closed