Issue 99414 - Hebrew parentheses during presentation - wrong direction
Hebrew parentheses during presentation - wrong direction
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: viewing
OOO300m9
All All
: P3 normal with 1 vote (vote)
: 4.0.0
Assigned To: groucho266
:
: 110270 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 12:25 UTC by tzuktz
Modified: 2013-07-15 12:11 UTC (History)
7 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation on: 3.4.1
Developer Difficulty: ---


Attachments
bugdoc (10.32 KB, application/vnd.oasis.opendocument.presentation)
2009-02-20 07:02 UTC, hennerdrewes
no flags Details
Screenshot OOO310_m1i (2.57 KB, image/png)
2009-02-20 07:17 UTC, hennerdrewes
no flags Details
screenshots (901.42 KB, image/png)
2009-02-20 07:58 UTC, wolframgarten
no flags Details
patch to add bidi support to DirextX canvas (5.96 KB, patch)
2009-09-23 08:58 UTC, hennerdrewes
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description tzuktz 2009-02-19 12:25:56 UTC
When using parentheses with Hebrew in a presentation they look OK during editing
but wrong during presentation.
Comment 1 wolframgarten 2009-02-19 12:29:03 UTC
Please attach a document for testing. Thanks.
Comment 2 hennerdrewes 2009-02-20 07:02:28 UTC
Created attachment 60317 [details]
bugdoc
Comment 3 hennerdrewes 2009-02-20 07:17:01 UTC
Attached bugdoc.

The mirroring of the parentheses seems to be fixed in OOO310_m1.

However, there is another problem. Will attach screenshot. 
The parentheses are misplaced, probably because the text string is handled in
LTR order instead of RTL. If you set the text direction to LTR, you will get the
same placement in edit mode.
Comment 4 hennerdrewes 2009-02-20 07:17:53 UTC
Created attachment 60318 [details]
Screenshot OOO310_m1i
Comment 5 wolframgarten 2009-02-20 07:57:09 UTC
In ooo310m1 the doc looks ok for me in edit mode and in presentation mode. After
setting the text to LTR I can see the problem of your screenshot.  I have
attached some screenhots: is this the problem you see?
Comment 6 wolframgarten 2009-02-20 07:58:24 UTC
Created attachment 60319 [details]
screenshots
Comment 7 hennerdrewes 2009-02-23 08:02:31 UTC
I get the same "directly after opening" result. However, when I go to
presentation mode, I get the LTR result, even if the text was set to RTL in edit
mode. 

Checked this on Vista Sp1. Will check the document again on XP later on, could
be Vista specific, if you failed to reproduce on XP.
Comment 8 hennerdrewes 2009-02-23 10:23:59 UTC
@wg: I can reproduce the effect also on Win XP. 

Under Tools, Options, View: Hardware acceleration is turned on. If I turn it
off, the display is correct also in presentation mode.
Comment 9 hennerdrewes 2009-09-23 08:58:13 UTC
Created attachment 64910 [details]
patch to add bidi support to DirextX canvas
Comment 10 hennerdrewes 2009-09-23 09:03:56 UTC
In dx_textlayout.cxx, settings for text direction were simply ignored.

I copied the corresponding code from vcl based textlayout.cxx to
dx_textlayout.cxx and dx_textlayout_drawhelper.cxx, and this seems to fix the
problem.
Comment 11 hdu@apache.org 2009-09-23 09:17:31 UTC
+1
Comment 12 alan 2009-09-24 08:22:33 UTC
There was some discussion of this problem in the comments to issue 95259. 
Comment 13 kaplanlior 2010-08-14 17:32:26 UTC
ping ? Any news about the patch ?
Comment 14 Rob Weir 2013-03-11 14:59:09 UTC
I'm adding this comment to all open issues with Issue Type == PATCH.  We have 220 such issues, many of them quite old.  I apologize for that.  

We need your help in prioritizing which patches should be integrated into our next release, Apache OpenOffice 4.0.

If you have submitted a patch and think it is applicable for AOO 4.0, please respond with a comment to let us know.

On the other hand, if the patch is no longer relevant, please let us know that as well.

If you have any general questions or want to discuss this further, please send a note to our dev mailing list:  dev@openoffice.apache.org

Thanks!

-Rob
Comment 15 hennerdrewes 2013-03-12 10:51:11 UTC
The problem still persists in current version 3.4.1

I don't see any relevant changes made to the source files on trunk recently, so I assume that the patch is still applicable. 

Unfortunately I don't have a build environment set up at the moment to verify.
Comment 17 SVN Robot 2013-03-12 12:21:03 UTC
"hdu" committed SVN revision 1455505 into trunk:
#i99414# add bidi support to the DirextX canvas
Comment 18 hdu@apache.org 2013-03-12 12:25:14 UTC
Applied for AOO4.0.
Henner: Thanks for the patch! Good to hear from you!
Lior and Alan: Thanks for the links!
Comment 19 hdu@apache.org 2013-07-12 09:52:05 UTC
*** Issue 110270 has been marked as a duplicate of this issue. ***
Comment 20 hdu@apache.org 2013-07-15 12:11:55 UTC
Closing resolved issue.