Issue 99535 - Writer crashes, exporting graphics from r/o docs
Summary: Writer crashes, exporting graphics from r/o docs
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOo 3.0.1
Hardware: PC Windows XP
: P2 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
: 104124 (view as issue list)
Depends on:
Blocks:
 
Reported: 2009-02-23 13:41 UTC by apo_pq
Modified: 2013-08-07 14:44 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description apo_pq 2009-02-23 13:41:08 UTC
First of all:  I use OO in German. 
Second:        It's version OOO300m15 (Build: 9379)
               (despite the information given in the issues header;
               sorry, didn't know how to enter correct version code!)

Consider we open an existing odt-file read only (file system attribute),
containing a desired graphic. Now try to export this graphic from the file:

Navigate to the graphic, 
right click on it, 
choose "Grafik speichern..."  (i.e. "Save graphic" I'd assume)
 -
OO crashes showing the following message:


---------------------------
Microsoft Visual C++ Runtime Library
---------------------------
Runtime Error!

Program: C:\Program Files\OpenOffice.org 3\program\soffice.bin

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.
---------------------------
OK   
---------------------------


Notice:
While this message is not confirmed, you still may successfully save and close
your other open OO-documents. Clicking 'OK', it's all over...
Comment 1 michael.ruess 2009-02-23 16:45:12 UTC
MRU->OS: open a document in read-only mode, right-click on a graphic and select
"Save graphic..." -> C++ Runtime error.

Please pay attention, that this is not mixed up with the problem from issue
99167 (Crash with file dialog after a toolbar is removed).
Comment 2 Oliver Specht 2009-06-17 07:28:16 UTC
Fixed in cws os132 in 
sw/source/ui/docvw/romenu.cxx

Created issue 102856 about the missing preset of the file name.
Comment 3 Oliver Specht 2009-07-13 14:56:22 UTC
Reassigned for verification
Comment 4 michael.ruess 2009-07-14 13:43:35 UTC
Verified fix in CWS os132.
Comment 5 michael.ruess 2009-09-17 12:17:22 UTC
Checked in DEV300m58.
Comment 6 Oliver Specht 2009-11-09 10:51:41 UTC
*** Issue 104124 has been marked as a duplicate of this issue. ***
Comment 7 onyx_nz 2010-02-22 21:12:11 UTC
Just struck this bug in version 3.2.0 running on Linux (Archlinux 64bit).
Comment 8 michael.ruess 2010-02-23 08:49:44 UTC
mru->onyx_nz: the build from you distributor or native build downloaded from
openoffice.org?