Issue 99541 - mailmerge: cannot edit flat address books created in mail merge dialog
Summary: mailmerge: cannot edit flat address books created in mail merge dialog
Status: CLOSED DUPLICATE of issue 97577
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 3.0.1
Hardware: All Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: Oliver Specht
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-23 15:18 UTC by caolanm
Modified: 2013-08-07 14:44 UTC (History)
1 user (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
patch to fix (796 bytes, patch)
2009-02-23 15:19 UTC, caolanm
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description caolanm 2009-02-23 15:18:59 UTC
In tools->mailmerge wizard if we create a new address book from create, we are
unable to later edit it if we restart OOo. The URL is a
sdbc:flat:/file/system/path with sdbd:flat: stripped off it but we pass it to
SfxMedium which needs a file URL.

Patch attached to convert /file/system/path to file:// + that dir which makes it
work
Comment 1 caolanm 2009-02-23 15:19:16 UTC
Created attachment 60391 [details]
patch to fix
Comment 2 andreas.martens 2009-02-24 08:00:38 UTC
ama->os: Please have a look at this mailmerge patch...
Comment 3 Oliver Specht 2009-02-24 08:59:06 UTC
Target set
Comment 4 Oliver Specht 2009-09-30 09:32:08 UTC
Target changed to 3.x
Comment 5 caolanm 2009-10-10 08:59:40 UTC
The code now reads...

sURL = String(sDBURL).Copy( 10 );
//#i97577# at this point the 'URL' can also be a file name!
sURL = URIHelper::SmartRel2Abs( INetURLObject(), sURL );

which is an alternate fix to the fix here and should solve the same problem. 


*** This issue has been marked as a duplicate of 97577 ***
Comment 6 caolanm 2009-10-10 09:01:28 UTC
closing duplicate effort