Issue 99585 - opening powerpoint file causes impress to use all memory and be OOM killed
Summary: opening powerpoint file causes impress to use all memory and be OOM killed
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: open-import (show other issues)
Version: OOo 3.0.1
Hardware: Unknown All
: P2 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: wolframgarten
QA Contact: issues@graphics
URL: https://bugs.launchpad.net/bugs/332648
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-24 15:49 UTC by ccheney
Modified: 2013-08-07 15:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description ccheney 2009-02-24 15:49:21 UTC
Attempting to open this document causes OpenOffice to consume all available
memory and be OOM killed. I tried it on a machine that has 4GB of ram and it
used it all...

http://launchpadlibrarian.net/22955894/Toon_Hermans-_Pascha.pps

Verified on official OOo 3.0.1.
Comment 1 wolframgarten 2009-02-25 08:39:41 UTC
Reproducible. Reassigned.
Comment 2 sophia 2009-11-22 14:33:59 UTC
I couldn't achieve to open a pptx presentation which has size of 264 MB.

Quite all my system physical memory is used (3GB).

Openoffice Impress froze with a popup with the "Microsoft Visual C++ Runtime
Library" title which told that there was not enough space anymore.

Openoffice version : 3.1.1 OOO310m19 (Build9420) for Microsoft Windows Vista 32
bits service pack 2
Comment 3 sven.jacobi 2011-01-31 17:54:50 UTC
sj: The bugdoc http://launchpadlibrarian.net/22955894/Toon_Hermans-_Pascha.pps
is encrypted and such PowerPoint documents can't be loaded with OOo. Indeed we
fixed not to crash if trying to open encrypted documents, this has been fixed,
you will get a message telling you that this file is encrypted and can't be loaded.

The problem Sophia brought up seems to be something different (because of the
huge filesize), without having a bugdoc, it will not be possible to be more precise.
Comment 4 sven.jacobi 2011-01-31 17:57:39 UTC
sj->wg: can you please verify and close this issue.
Comment 5 wolframgarten 2011-02-01 13:49:54 UTC
Tested in OOO330_m20. Closed.