Issue 9984 - Next record field in label document does not work
Next record field in label document does not work
Status: CLOSED DUPLICATE of issue 9672
Product: Writer
Classification: Application
Component: code
OOo 1.0.1
PC Windows NT
: P1 trivial (vote)
: ---
Assigned To: eric.savary
issues@sw
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-10 18:49 UTC by kingshome
Modified: 2003-09-08 16:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description kingshome 2002-12-10 18:49:26 UTC
The following bug report is probably related to Issue 9672, but goes beyond the
generation of a random number of duplicates.  I have tested this on ooo1.0.1,
ooo643c beta, staroffice 6 patch 2.

Summary:
OS NT4 SP6.  Ooo1.0.1; ooo643c; StarOffice 6 patch 2
When a ‘form letter’ is produced using the document produced from the label
wizard, the ‘Next record’ field only works correctly if there is one field in
each record.  When there is more than one field, the ‘Next record’ field
inserted in the labels has no effect (except to generate a random number of
duplicates – see issue 9672), and all records on the label sheet are the same.
Deleting the ‘Next record’ field, reinserting it manually, and synchronising
labels overcomes the problem.
Procedures a+b demonstrate what ought to happen.
Procedures c+d demonstrate the bug.
Procedure followed:

a	Generation of label document with one field per record.
******************************************************
Click on File – New – labels - labels dialog box appears.
On the right hand side select the correct database and table you wish to use. 
On the right hand side, under ‘Database Fields’, select one field and click the
large left pointing arrow at each point to place it on the label.
On the Options tab, make sure that 
	entire page
	synchronise contents 
			are ticked.
Click on the New Document button 
You can press Ctrl-F9 to view the fields.
There should be 2 fields at this point – the one you inserted and the ‘Next
recordÂ’ field.

(Note
Sometimes the field  ‘Next record’ does not appear at this point.  I can find
nothing consistent about the behaviour.
If the field ‘Next record’ does not appear, it has to be entered with Insert –
Fields – Other (Ctrl-F2), click on ‘Database’ tab – Next record – Insert
If this is the case, then manual insertion of the ‘Next record’ field gets rid
of the bug anyway)

b	Producing the set of labels from the database
*********************************************
Click on File – Form letter 
In the form letter dialogue box you should see the database table. 
Select the records you want on the label by clicking on the row headers.
Choose output to printer.  
Click on OK.  If you get a message that the ‘show fields’ option is checked,
choose not to show fields.
(At this point ooo643c beta crashes with an application error: ‘ The instruction
at ‘0x7800b936’ referenced memory at 0x00000003.  The memory could not be written’
If, however, you choose to print a specific number of records e.g. 1-20, then it
works OK)
The print dialogue box appears
Click on OK to print.
You should get a set of labels with a different record in each label.
(Note if you print to file rather than printer, you do not get a different
record in each label.  I think this must be another bug)

c	Generation of label document with more than one field per record.
*************************************************************

Click on File – New – labels - labels dialog box appears.
On the right hand side select the correct database and table you wish to use. 
On the right hand side, under ‘Database Fields’, select one field at a time and
click the large left pointing arrow at each point to place it on the label. 
Make sure your label contains more than one field.
On the Options tab, make sure that 
	entire page
	synchronise contents 
			are ticked.
Click on the New Document button 
You can press Ctrl-F9 to view the fields.
There should be all the fields you added, plus the ‘Next record’ field.
(Note
Sometimes the field  ‘Next record’ does not appear if the number of fields is
less than 3.
If the field ‘Next record’ does not appear, it has to be entered with Insert –
Fields – Other (Ctrl-F2), click on ‘Database’ tab – Next record – Insert
If this is the case, then manual insertion of the ‘Next record’ field gets rid
of the bug anyway)

d	Producing the set of labels from the database
********************************************
Click on File – Form letter 
In the form letter dialogue box you should see the database table. 
Select the records you want on the label by clicking on the row headers.
Choose output to printer.  
Click on OK.  If you get a message that the ‘show fields’ option is checked,
choose not to show fields.
(At this point ooo643c beta crashes with an application error: ‘ The instruction
at ‘0x7800b936’ referenced memory at 0x00000003.  The memory could not be written’
If, however, you choose to print a specific number of records e.g. 1-20, then it
works just like ooo1.0.1 ie it runs away as documented in Issue 9672)

The print dialogue box appears
Click on OK to print.
At this point the random duplicate number of labels is printed as reported in
Issue 9672 AND **the labels that are printed are all the same**, with only the
first record being printed over and over again, instead of multiple records per
label sheet.

The only way I have found to get round this is to delete the ‘Next record’ field
from the document produced in Procedure c., reinsert it by means of Insert –
Fields (Ctrl-F2), click on database tab – Next record – Insert, and synchronise
the labels.  Then the form letter works correctly.
Comment 1 h.ilter 2002-12-11 13:38:08 UTC
Reassigned to ES
Comment 2 kingshome 2002-12-16 12:47:53 UTC
16-12-02

Following my previous report, I have identified another case in which
the Next record field in labels does not work.  This has been tested
on ooo1.0.1 and ooo643beta.

Procedure
Intially the same as before:
Click on File – New – labels - labels dialog box appears.
On the right hand side select the correct database and table you wish
to use. 
On the right hand side, under ‘Database Fields’, select one field at a
time and click the large left pointing arrow at each point to place it
on the label.  Make sure your label contains more than one field.
On the Options tab, make sure that 
	entire page
	synchronise contents 
			are ticked.
Click on the New Document button 
You can press Ctrl-F9 to view the fields.
There should be all the fields you added, plus the ‘Next record’ field.
(Note
Sometimes the field  ‘Next record’ does not appear if the number of
fields is less than 3.
If the field ‘Next record’ does not appear, it has to be entered with
Insert – Fields – Other (Ctrl-F2), click on ‘Database’ tab – Next
record – Insert
If this is the case, then manual insertion of the ‘Next record’ field
gets rid of the bug anyway)

Change in procedure:

Press F4 to open up the data source.
Select the records you wish to have printed out.
On the data source toolbar, click on the 'data to fields' icon.  This
should populate your label document with the records you selected. 
However, it does not – you get multiple copies of the first record.

The solution is as above for using the form letter approach.  After
generating the new label document, delete the Next record field in the
first (master) record, reinsert it with Insert – Fields – Other –
Database tab – next record, synchronise the labels, and then clicking
on 'data to fields' will work correctly.

Comment 3 eric.savary 2002-12-19 11:34:56 UTC
Duplicate

*** This issue has been marked as a duplicate of 9672 ***
Comment 4 eric.savary 2002-12-19 11:35:15 UTC
closed