Issue 99847 - <Enter> key does not work when entering password of a file
Summary: <Enter> key does not work when entering password of a file
Status: CLOSED DUPLICATE of issue 99885
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOO310m3
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-04 08:06 UTC by orwel
Modified: 2009-03-30 11:13 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
password: 123456 (24.07 KB, application/vnd.oasis.opendocument.spreadsheet)
2009-03-04 08:08 UTC, orwel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description orwel 2009-03-04 08:06:39 UTC
If you open an ods file protected by password, in the field you enter password
the ENTER key does not function and you have to click on OK button with the
mouse. In 3.0.1 version it was possible to enter password also with ENTER key on
keyboard.

The other problem, if you want to re-save a password protected file without a
password and you try it to do through saving the file with the same name (File -
save as) only by unchecking the mark "Save with password" OOo will not do it.
The old value of the password is still saved in the document. So if you need to
remove the password you have also to change the name of the file.

The same problems occure in Writer.

See attached file (pass: 123456).
Comment 1 orwel 2009-03-04 08:08:07 UTC
Created attachment 60660 [details]
password: 123456
Comment 2 stefan.baltzer 2009-03-30 10:25:51 UTC
PW dialog focus (not on OK button when PW is entered): Duplicate.

*** This issue has been marked as a duplicate of 99885 ***
Comment 3 stefan.baltzer 2009-03-30 11:13:43 UTC
I adjusted the summary of this one to match the decription. Note that not only
spreadsheets are affected (See issue 99885 "No button in password dialog get the
focus while loading a docuement"
SBA->Orvel: Please note that most descriptions starting with "The other
problem...." make a so-called collective issue. Collective issues are invalid
because they can not be handled.
 
Feel free to look if that one already exists or write a new one for that.

Closing this duplicate.