Issue 99919 - Hyperlinks do not work, when presentation is running
Summary: Hyperlinks do not work, when presentation is running
Alias: None
Product: Impress
Classification: Application
Component: ui (show other issues)
Version: OOO310m2
Hardware: All All
: P2 Trivial (vote)
Target Milestone: OOo 3.1
Assignee: wolframgarten
QA Contact: issues@graphics
Keywords: regression
Depends on:
Blocks: 95768
  Show dependency tree
Reported: 2009-03-05 12:18 UTC by Stefan Weigel
Modified: 2009-03-19 11:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description Stefan Weigel 2009-03-05 12:18:24 UTC
Try this:

(1) Create a new presentation
(2) Choose Insert|Hyperlink
(3) Define a hyperlink (any target, any type)
(4) Run presentation
(5) Click hyperlink --> nothing happens

Found this bug with
- Ubuntu Linux 7.10 and OOO310m2
- Ubuntu Linux 8.10 and OOO310m3
Comment 1 Stefan Weigel 2009-03-05 12:19:21 UTC
Did work with OOo 3.0.1 --> regression
Comment 2 wolframgarten 2009-03-05 12:26:19 UTC
Reproducible. Reassigned.
Comment 3 wolframgarten 2009-03-05 12:58:48 UTC
@mechtilde: why do you kill the target but set it to prio 2?
Comment 4 groucho266 2009-03-05 13:15:11 UTC
Hm, strange. I checked this with DEV300 milestones.  On child work spaces (with
bug fixes) m38,m39,m41 it worked as it should.  The freshly installed m42 failed.
Comment 5 Mechtilde 2009-03-05 13:26:34 UTC
@ wg 

sorry for that. It seems I did it at the same time so it was overwritten

therefore I change it again.
Comment 6 Stefan Weigel 2009-03-05 13:29:19 UTC
I would like to propose this as showstopper for OOo 3.1:

A person showing a presentation that worked fine with OOo 3.0.1 and earlier
could run into a very embarrassing situation when using OOo 3.1. Nobody would
expect such a regression and nobody would check every click of an already
working presentation over and over again. So the bug would probably hit the
presenter unexpectedly during his/her talk.

The bug forces the lecturer to end the show and change back to edit mode of
Impress in order to be able to follow the hyperlink. After that he/she must
restart the presentation.
Comment 7 wolframgarten 2009-03-05 13:53:57 UTC
Must have get into product between m1 and m2. Works in m1.
Comment 8 mikhail.voytenko 2009-03-06 11:46:37 UTC
The problem is that newly used SID_OPENHYPERLINK slot is not known in the slide
show. Sending the bug to myself as discussed.
Comment 9 mikhail.voytenko 2009-03-06 12:24:43 UTC
Setting the target.
Comment 10 mikhail.voytenko 2009-03-06 12:28:42 UTC
Fixed in mav48.

By the way, on some OS the new opened for hyperlink window is not shown over the
full-window slide show.
Comment 11 mikhail.voytenko 2009-03-09 12:34:22 UTC
mav->wg: Please verify the issue.
Comment 12 wolframgarten 2009-03-09 16:22:40 UTC
Verified in CWS.
Comment 13 wolframgarten 2009-03-19 11:43:53 UTC
Tested in OOO310_m6. Closed.