Issue 99956 - openoffice should not present ASCII filter options if opening a zero size document
Summary: openoffice should not present ASCII filter options if opening a zero size doc...
Status: CLOSED DUPLICATE of issue 99646
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 3.0
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-06 10:01 UTC by donpaolo
Modified: 2009-03-06 10:28 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description donpaolo 2009-03-06 10:01:42 UTC
If I want to create a new document, I can create it as a 0-sized document with
gnome new document feature, and rename it to something.odt.

When I open it with Oo.o, Oo.o presents me the ASCII filter options, the same
way as it were opening a text only file. However, it is obvious that those
options have no meaning in case of a null document, so I consider that Oo.o
should not present those options in such a case.

Besides that, that options windows is confusing the user, because nobody expects
to see it, and the user could remain astonished.
Comment 1 eric.savary 2009-03-06 10:28:24 UTC
A 0 byte file *is* a text file thus OOo shoes the text import dialog.
OOo doesn't look at the size of the doc but at the magic (fingerprint) of the doc.

*** This issue has been marked as a duplicate of 99646 ***
Comment 2 eric.savary 2009-03-06 10:28:35 UTC
closed