Issue 99981 - Form date controls do not pickup custom formatting set in table definition
Summary: Form date controls do not pickup custom formatting set in table definition
Status: CLOSED WONT_FIX
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOO310m4
Hardware: Unknown All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: Frank Schönheit
QA Contact: issues@dba
URL:
Keywords:
: 99982 (view as issue list)
Depends on:
Blocks:
 
Reported: 2009-03-06 16:19 UTC by rk601
Modified: 2013-08-07 15:45 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description rk601 2009-03-06 16:19:22 UTC
OpenOffice Base 3.01 in Windows XP does not save its formatting when applied to
a Date field. Follow these steps to reproduce the error:

1. Launch OpenOffice 3.01, Create a database using OpenOffice HSQL database engine.

2. Create a table that includes at least one date field.

3. Click on the Field Type (Date) and change the "Format Example" to MM/DD/YYYY

4. Click the OK button, click the save button, and save the database.

5. Create a Form that allows for data to be entered into the newly created table
and allow the Form to edit database data. Be sure the Form allows for the
display and edit the Date field.

6. Save the Form.

7. Use the Form to enter data. Notice that the date field within the form does
not maintain its format; the date field defaults to MM/DD/YY.

8. You may need to quit OpenOffice a few times to see that the date field within
the form does not maintain its format. Also note that the the date field within
the Table defaults to its original format.
Comment 1 Frank Schönheit 2009-03-06 16:21:26 UTC
submitted twice

*** This issue has been marked as a duplicate of 99980 ***
Comment 2 Frank Schönheit 2009-03-06 16:23:16 UTC
closing duplicate
Comment 3 Frank Schönheit 2009-03-09 14:12:54 UTC
uhm, closed in error ... issue 99980 talks about numeric fields, this one here
about date fields. Though it might well be both have the same root cause, I
reopen this one here for the moment - I wrongly assumed both issues were identical.
Comment 4 Frank Schönheit 2009-03-09 14:13:14 UTC
.
Comment 5 rk601 2009-06-02 16:48:28 UTC
Due to fs@openoffice.org incorrect listing that this issue #99981 was a
duplicate. We resubmitted the issues as #99982 before fs@openoffice.org
corrected the issue error. Please note that issue #99981 and #99982 are the same
issue.
Comment 6 Mechtilde 2009-06-29 15:58:50 UTC
which regio settings under "Tools -> Options -> Language -> Language settengs
did you use?
Comment 7 Mechtilde 2009-07-30 14:06:48 UTC
*** Issue 99982 has been marked as a duplicate of this issue. ***
Comment 8 drewjensen.inbox 2009-07-31 16:21:12 UTC
Confirmed w/ OOO310m_17 and OO.o3.1, Unubtu 9.04

You can use the odb file attached to
http://www.openoffice.org/issues/show_bug.cgi?id=99980 to reproduce this.

Datagrid views for Table objects or Query definition objects do use the format -
it is only form controls that seem to have this problem. Altered summary to match
Comment 9 drewjensen.inbox 2009-07-31 16:22:04 UTC
Assign to developer

Set initial target
Comment 10 Frank Schönheit 2009-08-11 14:25:11 UTC
Date fields are not expected to pick the format of the underlying table column,
this feature is available or formatted fields only. One major reason is that
date fields have a limited formats list only, so 90 percent of all possible date
formats you can imagine cannot be reflected in date fields, anyway.
Comment 11 drewjensen.inbox 2009-08-11 14:41:20 UTC
@rk601 I recently showed an example of using a formatted field for displaying
date time in a post at the forums. http://tinyurl.com/n69s5m just for a
reference perhaps.
Comment 12 Mechtilde 2009-09-07 13:54:56 UTC
wontfix -> closed