Bug 58439

Summary: [PATCH] Rename private FormulaShifter.adjustPtgDueToShiftMove to adjustPtgDueToSheetMove
Product: POI Reporter: Javen O'Neal <onealj>
Component: SS CommonAssignee: POI Developers List <dev>
Severity: enhancement    
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Hardware: PC   
OS: Linux   
Bug Depends on:    
Bug Blocks: 58348    
Attachments: rename adjustPtgDueToShiftMode to adjustPtgDueToSheetMove

Description Javen O'Neal 2015-09-21 20:49:13 UTC
Created attachment 33123 [details]
rename adjustPtgDueToShiftMode to adjustPtgDueToSheetMove

In FormulaShifter.java, the private method adjustPtgDueToShiftMove adjusts the sheet field of a Ref3DPtg after a sheet has been moved. This was added in r1142219 as a fix for bug 48294.

To differentiate a sheet move from a row move, I think a more appropriate name for this method is adjustPtgDueToSheetMove. This also aligns the name with the public static createForSheetShift method.

Because this method is private, it shouldn't affect any other files or existing code.
Comment 1 Javen O'Neal 2015-10-23 09:01:36 UTC
Implemented in r1710147 <https://svn.apache.org/viewvc?view=revision&revision=1710147>.

Deployed to trunk.