Bug 14416 - blank tag name in TLD cause NullPointerException
blank tag name in TLD cause NullPointerException
Status: RESOLVED FIXED
Product: Tomcat 4
Classification: Unclassified
Component: Jasper
4.1.12
PC All
: P3 enhancement (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2002-11-10 05:16 UTC by Naohito Sato
Modified: 2010-12-17 08:52 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Naohito Sato 2002-11-10 05:16:20 UTC
In case a blank tag name exists in TLD like follows,

  <tag>
    <name/>
    <tag-class>foo.BarTag</tag-class>
  </tag>

Jasper jspc reports

% $JASPER_HOME/bin/jasper.bat jspc

error:null

To found this reason, I took few hours.
I want Jasper jspc to report more details!
Comment 1 Mark Thomas 2004-02-09 23:55:20 UTC
This is an enhancement request, not a bug.
Comment 2 Mark Thomas 2010-12-17 08:52:23 UTC
Just tested this with 7.0.x and with if deploying a web application with such a TLD full details are provided.

With JspC, the NPE from TagLibraryInfo did mask the problem. I have made that method more robust when it comes to handling nulls.