Bug 21799 - Putting port as user defined variable stops update of URL on XML-RPC Sampler
Putting port as user defined variable stops update of URL on XML-RPC Sampler
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: HTTP
Nightly (Please specify date)
PC All
: P3 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2003-07-22 14:54 UTC by Ian Fairman
Modified: 2005-03-20 17:06 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Fairman 2003-07-22 14:54:47 UTC
Nightly Build 2003/07/20

Actions:
1) Start JMeter
2) Under "Test Plan" add a "Thread Group"
3) Under the "Thread Group" add two "SOAP/XML-RPC Request" samplers.
4) With the focus on the first sampler set the URL to "http://${host}/"
5) Switch focus to second sampler then back again to the first.
6) Change the URL to "http://${host}:${port}/"
7) Switch focus to second sampler then back again to the first.

Expected Behaviour:
The URL of the first sampler should be "http://${host}:${port}/"

Actual Behaviour:
The URL of the first sampler is "http://${host}/"

General Behaviour:
Setting any URL for this sampler to have a user defined variable for the port
prevents the new value of the URL being saved.
Comment 1 Joshua Slive 2003-07-31 15:15:24 UTC
*** Bug 22023 has been marked as a duplicate of this bug. ***
Comment 2 Joshua Slive 2003-07-31 15:17:33 UTC
Sorry, that duplicate was a typo.