Bug 24684 - remote startup problems if spaces in the path of the jmeter
remote startup problems if spaces in the path of the jmeter
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
1.9.1
PC All
: P2 minor (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2003-11-13 15:30 UTC by Emmanuel Cornette
Modified: 2007-05-13 15:07 UTC (History)
1 user (show)



Attachments
Suggested patch (1.81 KB, patch)
2007-05-10 23:51 UTC, Alf Hogemark
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Emmanuel Cornette 2003-11-13 15:30:15 UTC
Hi,

I launched a set of JMeter servers on several PC (PII 2Ghz) with a client on 
one of them.

When launching the jmeter console and trying to use the "remote start" command 
to execute the jmeter server located on the same computer, jmeter shows me a 
pop-up : "bad call to remote host"

I looked in the log file of jmeter and saw a java.rmi.NotBoundException due to 
a java.net.MalformedURLException : no protocol : and. This word "and" is the 
word following the first space in the path of the jmeter directory 
(in "documents and settings").

I moved the jmeter directory to a path without spaces and it works fine.

I hope it helps
Comment 1 Jordi Salvat i Alabart 2004-01-23 01:58:41 UTC
Downgrading this to severity Minor, since it has an easy workaround.
Comment 2 Bernd Wellhoefer 2007-02-28 03:22:57 UTC
Hhhm IMHO this bug should get a higher priority. Nevertheless I knew about this
bug, I lost two hours to find out why remote JMeter runs did not work...

I'm pretty sure that a lot of JMeter users try remote JMeter runs and have no
success because of this bug e.g. the Windows Desktop folder has a space in the
path. 

Moreover the bug is now more then 3 years old... 

I will raise the priority to P2. Ok?

Regards,

Bernd
Comment 3 Alf Hogemark 2007-05-10 00:50:28 UTC
This problem is really caused by Java bug, see
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4496398

So there is no way to fix this in Jmeter.
Comment 4 Sebb 2007-05-10 03:47:19 UTC
(In reply to comment #3)
> This problem is really caused by Java bug, see
> http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4496398
> So there is no way to fix this in Jmeter.

Well done finding the bug report!

We should probably add a warning message to JMeter when anyone tries to run 
client-server mode from the wrong kind of directory (I think it only affects 
one side).
Comment 5 Alf Hogemark 2007-05-10 05:59:47 UTC
(In reply to comment #4)
> We should probably add a warning message to JMeter when anyone tries to run 
> client-server mode from the wrong kind of directory (I think it only affects 
> one side).

I think it only affects the server side.
One way of solving it, is to add a check in the script that starts the server,
i.e. jmeter-server.bat and jmeter-server. If the directory contains spaces, just
output a warning, and do not attempt starting the server.

I also noticed that the jmeter-server.bat does not work well on Windows XP,
because it kills the rmiregistry right after the server is started. I guess a
separate bug should perhaps be filed for that issue.
Comment 6 Sebb 2007-05-10 06:23:40 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > We should probably add a warning message to JMeter when anyone tries to 
run 
> > client-server mode from the wrong kind of directory (I think it only 
affects 
> > one side).
> I think it only affects the server side.
> One way of solving it, is to add a check in the script that starts the 
server,
> i.e. jmeter-server.bat and jmeter-server. If the directory contains spaces, 
just
> output a warning, and do not attempt starting the server.

I think it would be better in the Java code - otherwise it would have to be 
added to all scripts - and users might create their own...

> I also noticed that the jmeter-server.bat does not work well on Windows XP,
> because it kills the rmiregistry right after the server is started. I guess a
> separate bug should perhaps be filed for that issue.

Works OK for me.
Yes, it kills the rmiserver, but only when the jmeter server has finished.
The "call jmeter" command should wait for the server to exit.
Or perhaps you have set JMeter to use JAVAW rather than JAVA?
Comment 7 Alf Hogemark 2007-05-10 23:51:09 UTC
Created attachment 20169 [details]
Suggested patch

I agree, it is much better to have the test in the java code.

Attached is a patch which checks the jmeter home on startup of server, and
exits if the jmeter path contains characters that will cause the RMI bind to
fail.

The jmeter-server.bat and the taskkill works fine for me know, I am not sure
what caused my problems.
Comment 8 Sebb 2007-05-13 15:07:26 UTC
Thanks. Fixed in SVN r537663.