Bug 25848 - ServletRequest.setCharacterEncoding() does not appear to work
ServletRequest.setCharacterEncoding() does not appear to work
Status: RESOLVED DUPLICATE of bug 23929
Product: Tomcat 5
Classification: Unclassified
Component: Connector:Coyote
All All
: P3 major (vote)
: ---
Assigned To: Tomcat Developers Mailing List
Depends on:
  Show dependency tree
Reported: 2003-12-31 21:38 UTC by Jess Holle
Modified: 2004-11-16 19:05 UTC (History)
0 users


Note You need to log in before you can comment on or make changes to this bug.
Description Jess Holle 2003-12-31 21:38:36 UTC
We have pages that process non-ASCII characters in request parameter values 
just fine with Tomcat 4.1.24 by encoding the URL request string (this is a GET 
request) and then using ServletRequest.setCharacterEncoding("UTF-8") when 
processing the resulting request.

This is failing in Tomcat 5.0.16 -- all else being held equal.

I've checked the bug database and see various issues with setCharacterEncoding
() and interactions with request dump valves, Jasper log-levels, etc.  I 
checked each one of these in my Tomcat 5 configuration and none of these are 

I have been poking around in the debugger and can't seem to find anything amiss 
(e.g. tell-tale use of parseRequestParameters() prior to use of 
setCharacterEncoding()), but I'm coming up empty thus far...
Comment 1 Remy Maucherat 2004-01-03 09:16:49 UTC

*** This bug has been marked as a duplicate of 23929 ***