Bug 28086 - Apache 2.0.49 crashes on graceful restart
Summary: Apache 2.0.49 crashes on graceful restart
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Core (show other bugs)
Version: 2.0.49
Hardware: All All
: P3 major with 11 votes (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
: 29825 (view as bug list)
Depends on:
Reported: 2004-03-31 12:23 UTC by Andy Fiddaman
Modified: 2004-11-16 19:05 UTC (History)
1 user (show)


Note You need to log in before you can comment on or make changes to this bug.
Description Andy Fiddaman 2004-03-31 12:23:19 UTC
When I rotate the logs using "apachectl graceful", the parent apache process 
crashes. Compiled as a 32-bit binary on Solaris 9 (64-bit kernel) and this 
problem does not exist in 2.0.48.

#0  0xfe925398 in ?? ()
#1  0x000d3514 in regcomp (preg=0x16df20, pattern=0x16df18 "^\\.ht", cflags=0)
    at pcreposix.c:206
#2  0x000ad7b0 in ap_pregcomp (p=0x11df58, pattern=0x16df18 "^\\.ht", cflags=0)
    at util.c:267
#3  0x000c5978 in filesection (cmd=0xffbffad0, mconfig=0x161c58,
    arg=0x16df09 "") at core.c:1765
#4  0x000a2cd4 in invoke_cmd (cmd=0xf78b4, parms=0xffbffad0, mconfig=0x161c58,
    args=0x163930 "~ \"^\\.ht\">") at config.c:670
#5  0x000a4784 in ap_walk_config_sub (current=0x163910, parms=0xffbffad0,
    section_vector=0x160c60) at config.c:1048
#6  0x000a487c in ap_walk_config (current=0x163910, parms=0xffbffad0,
    section_vector=0x160c60) at config.c:1087
#7  0x000a5f74 in ap_process_config_tree (s=0x121310, conftree=0x15f358,
    p=0x11df58, ptemp=0x15a048) at config.c:1621
#8  0x000aa6f0 in main (argc=4, argv=0xffbffc4c) at main.c:595
Comment 1 Jon Noack 2004-03-31 15:42:45 UTC
Confirmed on FreeBSD:

It also appears to be present on Linux as well:
Comment 2 Renato Botelho 2004-03-31 16:07:52 UTC
When I used apache-2.0.49 with php-4.3.4, it has worked right, when I compile
php-4.3.5 it starts to crash.

I recompile php-4.3.5, removing directory ext/pcre and putting the same
directory from php-4.3.4 and i run allright again, so, the problem is on pcre of
Comment 3 Renato Botelho 2004-03-31 19:26:37 UTC
The problem has been fixed by php developers

Comment 4 Jon Noack 2004-04-02 09:50:54 UTC
I still see this with PHP 4.3.6-RC1 (released 2 days after fix supposedly was in
PHP CVS).  Also, there is no mention of the fix in NEWS or Changelog nor was I
able to find it in CVS (it could still be there, I just couldn't find one).  In
any case, this doesn't appear to be fixed yet.  Are we sure this is a PHP
problem?  Someone posted to the PHP bug listed above that neither PHP 4.3.5 or
5.0.0-RC1 have problems with Apache 2.0.48, but both exhibit this broken
behavior with Apache 2.0.49.

In any case, I'm reopening.  Anyone who can shed light on this gets the prize...
Comment 5 Joe Orton 2004-04-18 11:55:35 UTC
It's most likely you are seeing the PHP bug http://bugs.php.net/bug.php?id=27810
- though there is also httpd bug 23952.

The PHP bug is that it leaves the global variables pcre_{malloc,free} pointing
at PHP functions, even after PHP is unloaded during a SIGHUP/SIGUSR1.  I'm using
this  patch: http://www.apache.org/~jorton/php-4.3.6-pcrealloc.patch
Comment 6 Oliver Feiler 2004-06-27 12:56:01 UTC
*** Bug 29825 has been marked as a duplicate of this bug. ***