Bug 34052 - Problem with Remote testing and WebService(SOAP) Request
Summary: Problem with Remote testing and WebService(SOAP) Request
Status: RESOLVED WONTFIX
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.0.2
Hardware: PC Windows 2000
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords: TestID
Depends on:
Blocks:
 
Reported: 2005-03-17 09:54 UTC by Angel Mazadiego
Modified: 2006-06-03 18:03 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Angel Mazadiego 2005-03-17 09:54:25 UTC
When i run a test load with remote testing feature and webservices request, the
server logs load times with errors. These times include time delays due to
jmeter    problems.
Comment 1 peter lin 2005-03-17 14:15:47 UTC
I'm not sure I understand the problem. Is the test setup this.

1. you have a webservice test plan that uses the webservice sampler
2. you're using multiple systems to do remote testing

Is that accurate. I should warn you that webservices scale horribly with respect
to concurrent load. If the xml parser your application is using is slow and eats
a ton of RAM, it's going to be hard to handle 20 concurrent webservice requests
on a 2.4ghz P4 system or 2ghz althon system.  This is from benchmarking with IIS
+ .NET and crimson for Java with tomcat.

with just one system, you can easily overload a webservice on the serverside.
especially if the webservice is making a call to a remote database and doing
real work.

peter
Comment 2 peter lin 2005-05-09 02:32:04 UTC
More information is needed to figure out exactly the cause.
Comment 3 Sebb 2006-06-04 01:03:21 UTC
Not enough information to be able to fix