Bug 34952 - Installer modifies windows service when it shouldn't
Installer modifies windows service when it shouldn't
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Native:Packaging
5.5.9
PC Windows XP
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2005-05-18 14:23 UTC by Gili
Modified: 2006-09-29 17:54 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gili 2005-05-18 14:23:14 UTC
1) Install one instance of Tomcat with "install service" enabled
2) Install second instance of Tomcat with "install service" disabled

The 2nd installation will modify the existing Tomcat service to point to the new
Tomcat installation path.

Expected behavior: The 2nd installation should not touch the service
configuration since the installer was explicitly instructed *not* to do anything
service-related.
Comment 1 Mark Thomas 2006-09-29 17:54:28 UTC
The windows installer always installs Tomcat as a service. The text and web site
could be clearer about this and I have made some changes. If you want to install
multiple services, don't use the installer, use service.bat.