Bug 35556 - CRL files not re-read by HUP
Summary: CRL files not re-read by HUP
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_ssl (show other bugs)
Version: 2.0.52
Hardware: Other other
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
Keywords: MassUpdate
Depends on:
Reported: 2005-06-30 01:35 UTC by Jason Haar
Modified: 2018-11-07 21:08 UTC (History)
0 users


Note You need to log in before you can comment on or make changes to this bug.
Description Jason Haar 2005-06-30 01:35:28 UTC
I have a CentOS 4.1 server running httpd-2.0.52-12.ent.centos4 using client
certificates for authentication. 

We have an internal CA that regenerates CRLs every hour, and they are signed as
being valid for 24 hours. We have an automated process for pushing those CRL
files out to Web servers and other devices that need them.

On this 2.0.52 server, the revocation data is referenced via:

SSLCARevocationFile /etc/httpd/conf/ssl.crl/Our-CA.crl

What is happening is that even though that file is being updated with a new CRL
file every hour, only a full restart (stop, start) of Apache makes it re-read
the CRL! If we send a HUP, it doesn't re-read it.

At that stage you see the "Found CRL is expired - revoking all certificates
until you get updated CRL" error message and noone can access the server via
certs any more.
Comment 1 André Malo 2005-08-14 12:29:24 UTC
I don't know, what this package includes. Have you tried using a more recent
version (2.0.54 is current)? Does the error log show something (that the restart
really happend, errors from mod_ssl)? Tried a vanilla httpd?
Comment 2 Joe Orton 2005-09-06 15:11:43 UTC
Can't reproduce here.  Could be a permissions/SELinux issue, possibly.  Can you
try running:

  strace -eopen `cat /var/run/httpd.pid`

as root and then HUP the server, and check whether the CRL file is opened OK.
Comment 3 Matt Miller 2007-07-18 11:39:47 UTC
This may be a more general, but related, bug.  We are using 2.0.58 and have 
simmilar issues when we change the crt or key files.  We have patches:

apache-ssldos apxs.envvars apxs.no-httpd-check http_banner http_method

Here I changed the crt:

# strace -eopen -p 1460
Process 1460 attached - interrupt to quit
--- SIGHUP (Hangup) @ 0 (0) ---
--- SIGHUP (Hangup) @ 0 (0) ---
--- SIGCHLD (Child exited) @ 0 (0) ---
open("/etc/httpd/conf/httpd.conf", O_RDONLY) = 5
open("/var/run/config/httpd.conf.d/mod_auth_pam.conf", O_RDONLY) = 6
open("/etc/httpd/modules/mod_auth_pam.so", O_RDONLY) = 14
open("/etc/ld.so.cache", O_RDONLY)      = 14
open("/lib/libpam.so.0", O_RDONLY)      = 14
open("/var/run/config/httpd.conf.d/ssl.conf", O_RDONLY) = 6
open("/etc/httpd/modules/mod_ssl.so", O_RDONLY) = 14
open("/etc/httpd/modules/mod_access.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_auth.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_auth_anon.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_auth_f5_auth_token.so", O_RDONLY) = 6
open("/etc/ld.so.cache", O_RDONLY)      = 6
open("/usr/lib/libf5util.so", O_RDONLY) = 6
open("/usr/lib/libcpp.so.11", O_RDONLY) = 6
open("/usr/lib/libmcp.so", O_RDONLY)    = 6
open("/usr/lib/libstdc++.so.5", O_RDONLY) = 6
open("/lib/libgcc_s.so.1", O_RDONLY)    = 6
open("/etc/httpd/modules/mod_include.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_log_config.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_env.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_expires.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_headers.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_setenvif.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_mime.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_autoindex.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_asis.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_negotiation.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_dir.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_actions.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_alias.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_cgi.so", O_RDONLY) = 6
open("/etc/httpd/modules/mod_jk2.so", O_RDONLY) = 6
open("/usr/lib/httpd/modules/mod_fastcgi.so", O_RDONLY) = 6
open("/etc/passwd", O_RDONLY)           = 5
open("/etc/group", O_RDONLY)            = 5
open("/etc/group", O_RDONLY)            = 5
open("/etc/passwd", O_RDONLY)           = 5
open("/etc/hosts", O_RDONLY)            = 5
open("/dev/null", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 2
open("/etc/httpd/conf/ssl.crt/server.crt", O_RDONLY) = 14
open("/etc/httpd/conf/ssl.crt/server.crt", O_RDONLY) = 14
open("/etc/httpd/conf/ssl.key/server.key", O_RDONLY) = 14
open("/etc/httpd/conf/ssl.key/server.key", O_RDONLY) = 14
open("/etc/httpd/logs/ssl_mutex.1456", O_WRONLY|O_CREAT|O_EXCL, 0644) = 14
open("/var/cache/mod_ssl/scache.dir", O_RDWR|O_CREAT, 0644) = 16
open("/var/cache/mod_ssl/scache.pag", O_RDWR|O_CREAT, 0644) = 17
open("/var/cache/mod_ssl/scache.dir", O_RDWR|O_CREAT, 0644) = 16
open("/var/cache/mod_ssl/scache.pag", O_RDWR|O_CREAT, 0644) = 17
open("/var/cache/mod_ssl/scache.dir", O_RDWR|O_CREAT, 0644) = 16
open("/var/cache/mod_ssl/scache.pag", O_RDWR|O_CREAT, 0644) = 17
Process 1460 detached
Comment 4 Matt Miller 2007-07-18 11:56:25 UTC
After further investigation, it looks like it is working as advertised except 
for /etc/rc.d/init.d/httpd reload.  The command and output:

# /etc/init.d/httpd reload
Reloading httpd: [  OK  ]

Here are the messages in httpd_errors:

Jul 18 11:34:12 mmiller-bigip1 httpd[1460]: [error] Unable to configure RSA 
server private key
Jul 18 11:34:12 mmiller-bigip1 httpd[1460]: [error] SSL Library Error: 
185073780 error:0B080074:x509 certificate routines:X509_check_private_key:key 
values mismatch
Comment 5 William A. Rowe Jr. 2018-11-07 21:08:24 UTC
Please help us to refine our list of open and current defects; this is a mass update of old and inactive Bugzilla reports which reflect user error, already resolved defects, and still-existing defects in httpd.

As repeatedly announced, the Apache HTTP Server Project has discontinued all development and patch review of the 2.2.x series of releases. The final release 2.2.34 was published in July 2017, and no further evaluation of bug reports or security risks will be considered or published for 2.2.x releases. All reports older than 2.4.x have been updated to status RESOLVED/LATER; no further action is expected unless the report still applies to a current version of httpd.

If your report represented a question or confusion about how to use an httpd feature, an unexpected server behavior, problems building or installing httpd, or working with an external component (a third party module, browser etc.) we ask you to start by bringing your question to the User Support and Discussion mailing list, see [https://httpd.apache.org/lists.html#http-users] for details. Include a link to this Bugzilla report for completeness with your question.

If your report was clearly a defect in httpd or a feature request, we ask that you retest using a modern httpd release (2.4.33 or later) released in the past year. If it can be reproduced, please reopen this bug and change the Version field above to the httpd version you have reconfirmed with.

Your help in identifying defects or enhancements still applicable to the current httpd server software release is greatly appreciated.