Bug 37452 - ConsoleAppender is actually a SystemOutAppender or SystemErrAppender
ConsoleAppender is actually a SystemOutAppender or SystemErrAppender
Status: RESOLVED DUPLICATE of bug 37122
Product: Log4j
Classification: Unclassified
Component: Appender
unspecified
Other other
: P2 normal
: ---
Assigned To: log4j-dev
:
Depends on: 31056
Blocks:
  Show dependency tree
 
Reported: 2005-11-10 17:40 UTC by emergency.shower
Modified: 2005-11-10 15:30 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description emergency.shower 2005-11-10 17:40:52 UTC
Since log4j version 1.2.12 ConsoleAppender always logs to System.out or 
System.err but not to the stream that was given to ConsoleAppender at the 
beginning of it's life cycle (normally stdout or stderr).

To log errors that occur in third party libraries, we redirect all output to 
System.out and System.err to a stream that uses log4j as output. If 
ConsoleAppender is configured as a appender, this will result in stack 
overflows or out-of-memory-errors.

See bug 31056, which was probably erroneously considered as a bug.
Comment 1 Curt Arnold 2005-11-11 00:30:21 UTC
In quickly forthcoming 1.2.13, ConsoleAppender's original behavior will be
restored as default, but there will be a new attribute "follow" that will allow
a user to cause ConsoleAppender to log to the current value of System.out or
System.err.

*** This bug has been marked as a duplicate of 37122 ***