Bug 38779 - Wrong class name in org/apache/catalina/cluster/tcp/mbeans-descriptors.xml
Wrong class name in org/apache/catalina/cluster/tcp/mbeans-descriptors.xml
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Catalina:Cluster
5.5.14
All All
: P3 trivial (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2006-02-24 16:21 UTC by Pawel Tucholski
Modified: 2006-04-11 08:07 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pawel Tucholski 2006-02-24 16:21:06 UTC
This bug is found in 5.5.15!!

In file org/apache/catalina/cluster/tcp/mbeans-descriptors.xml there is a class
section:
      <parameter name="message"
                 description="replication message"
                 type="org.apache.catalina..cluster.ClusterMessage"/>

So, org.apache.catalina..cluster.ClusterMessage should be replaced
with org.apache.catalina.cluster.ClusterMessage 

Without this fix there is an exception like below:
11:33:06 main [org.apache.catalina.cluster.tcp.SimpleTcpCluster]: INFO  Cluster
is about to start
11:33:07 main [org.apache.catalina.cluster.tcp.SimpleTcpCluster]: ERROR Cannot
instantiate ModelMBean of class org.apache.commons.modeler.BaseModelMBean
javax.management.MBeanException: Cannot instantiate ModelMBean of class
org.apache.commons.modeler.BaseModelMBean
        at org.apache.commons.modeler.ManagedBean.createMBean(ManagedBean.java:430)
        at
org.apache.catalina.cluster.tcp.SimpleTcpCluster.getManagedBean(SimpleTcpCluster.java:1340)
        at
org.apache.catalina.cluster.tcp.SimpleTcpCluster.registerMBeans(SimpleTcpCluster.java:1289)
        at
org.apache.catalina.cluster.tcp.SimpleTcpCluster.start(SimpleTcpCluster.java:732)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1002)
        at org.apache.catalina.core.StandardHost.start(StandardHost.java:718)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1012)
        at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:442)
        at org.apache.catalina.startup.Embedded.start(Embedded.java:821)
        at
fi.gtech.esi.player.channel.util.EmbeddedTomcat.start(EmbeddedTomcat.java:186)
        at
fi.gtech.esi.player.channel.mgmt.Management.startComponent(Management.java:306)
        at fi.gtech.esi.player.channel.mgmt.Management.start(Management.java:204)
        at fi.gtech.esi.player.channel.mgmt.Management.start(Management.java:129)
        at fi.gtech.esi.player.channel.mgmt.Management.main(Management.java:117)
Caused by: java.lang.IllegalArgumentException: Not a valid Java type name:
org.apache.catalina..cluster.ClusterMessage
        at javax.management.MBeanInfo.mustBeValidJavaTypeName(MBeanInfo.java:470)
        at javax.management.MBeanParameterInfo.<init>(MBeanParameterInfo.java:58)
        at
org.apache.commons.modeler.ParameterInfo.createParameterInfo(ParameterInfo.java:175)
        at
org.apache.commons.modeler.OperationInfo.createOperationInfo(OperationInfo.java:251)
        at
org.apache.commons.modeler.ManagedBean.createMBeanInfo(ManagedBean.java:480)
        at org.apache.commons.modeler.ManagedBean.createMBean(ManagedBean.java:424)
Comment 1 Peter Rossbach 2006-04-11 15:07:01 UTC
Thanks, that reporting this, fix at tomcat 5.5.17 release.