Bug 49223 - Parameters do not work in the "Send Files with the Request" Field
Summary: Parameters do not work in the "Send Files with the Request" Field
Status: RESOLVED DUPLICATE of bug 46901
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 2.3.4
Hardware: PC Windows XP
: P2 major (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-29 10:57 UTC by Gerald Steiner
Modified: 2010-04-29 11:04 UTC (History)
0 users



Attachments
Screen shot configuration (176.76 KB, image/jpeg)
2010-04-29 10:57 UTC, Gerald Steiner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Steiner 2010-04-29 10:57:14 UTC
Created attachment 25372 [details]
Screen shot configuration

In the HTTP Request Sampler it is not possible to use paramters in the "Send Files with the Request" field.

For the configuration details see the attached screen shot.

The content of the error file is as follows:

java.io.FileNotFoundException: ${requestFile_}${i} (The system cannot find the file specified)
	at java.io.FileInputStream.open(Native Method)
	at java.io.FileInputStream.<init>(Unknown Source)
	at java.io.FileInputStream.<init>(Unknown Source)
	at org.apache.jmeter.protocol.http.sampler.PostWriter.writeFileToStream(PostWriter.java:406)
	at org.apache.jmeter.protocol.http.sampler.PostWriter.sendPostData(PostWriter.java:115)
	at org.apache.jmeter.protocol.http.sampler.HTTPSampler.sendPostData(HTTPSampler.java:159)
	at org.apache.jmeter.protocol.http.sampler.HTTPSampler.sample(HTTPSampler.java:514)
	at org.apache.jmeter.protocol.http.sampler.HTTPSamplerBase.sample(HTTPSamplerBase.java:1037)
	at org.apache.jmeter.protocol.http.sampler.HTTPSamplerBase.sample(HTTPSamplerBase.java:1023)
	at org.apache.jmeter.threads.JMeterThread.process_sampler(JMeterThread.java:346)
	at org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:243)
	at java.lang.Thread.run(Unknown Source)
Comment 1 Sebb 2010-04-29 11:04:24 UTC

*** This bug has been marked as a duplicate of bug 46901 ***