Bug 49795 - Crash in Socket.destroy
Crash in Socket.destroy
Status: RESOLVED FIXED
Product: Tomcat Native
Classification: Unclassified
Component: Library
1.1.20
PC Linux
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
: 49796 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2010-08-22 01:40 UTC by mikew
Modified: 2011-03-10 06:09 UTC (History)
0 users



Attachments
stack dump (495.90 KB, text/plain)
2010-08-22 01:40 UTC, mikew
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mikew 2010-08-22 01:40:00 UTC
Created attachment 25924 [details]
stack dump

This is with APR 1.4.2 on Linux (CentOS 5.3).  (Also using Tomcat 6.0.29 and Tomcat Native 1.1.20.)

I don't know how to reproduce this, but I hope that the attached stack dump may point to the problem.
Comment 1 mikew 2010-08-22 01:42:36 UTC
This is a different seg fault / stack trace from Bug 49796.
Comment 2 Rainer Jung 2010-08-22 01:55:18 UTC
Moved from APR to Tomcat. I expect this needs investigation in tcnative.
See also BZ 49796, there's possibly a common root cause.
Comment 3 Mark Thomas 2010-09-28 17:45:58 UTC
Moving to tcnative
Comment 4 jfclere 2011-01-12 03:14:30 UTC
*** Bug 49796 has been marked as a duplicate of this bug. ***
Comment 5 Konstantin Kolinko 2011-02-02 11:22:05 UTC
AprEndpoint shutdown improvements were backported from trunk to 6.0 in r1065945 and will be in 6.0.32 onwards.
Comment 6 jfclere 2011-03-10 06:09:11 UTC
Fix in TC6 code.