Bug 50929 - [patch] Ensure rethrown exceptions retain the original cause
[patch] Ensure rethrown exceptions retain the original cause
Status: RESOLVED FIXED
Product: Tomcat 7
Classification: Unclassified
Component: Catalina
trunk
PC Windows XP
: P2 enhancement (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-03-14 11:08 UTC by Sebb
Modified: 2011-03-15 19:06 UTC (History)
0 users



Attachments
Patch to fix problem in some files (5.90 KB, patch)
2011-03-14 11:08 UTC, Sebb
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sebb 2011-03-14 11:08:56 UTC
Created attachment 26770 [details]
Patch to fix problem in some files

Where an exception is caught an rethrown, it helps to provide the original exception as the cause.
Comment 1 Mark Thomas 2011-03-15 19:06:02 UTC
Fixed in 7.0.x and will be included in 7.0.12 onwards.