Bug 50997 - StandardJarScanner ignores web-fragment.xml files in unpacked jars if they are not ending with ".jar"
StandardJarScanner ignores web-fragment.xml files in unpacked jars if they ar...
Status: RESOLVED FIXED
Product: Tomcat 7
Classification: Unclassified
Component: Catalina
7.0.11
PC Linux
: P2 minor (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-03-30 11:57 UTC by Rodion Zhitomirsky
Modified: 2011-03-30 16:07 UTC (History)
0 users



Attachments
Fix for directories in classpath not ending with .jar (1.49 KB, application/octet-stream)
2011-03-30 11:57 UTC, Rodion Zhitomirsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rodion Zhitomirsky 2011-03-30 11:57:49 UTC
Created attachment 26816 [details]
Fix for directories in classpath not ending with .jar

We use eclipse sysdeo tomcat plugin for eclipse. It allows us to add target build directories of eclipse into tomcat classpath. All works fine until we decided to use web-fragment functionality. It failed to work despite the config:

<JarScanner scanAllDirectories="true"/>

I fixed the problem. Please, see attached proposed patch.
Comment 1 Mark Thomas 2011-03-30 16:07:12 UTC
Thanks for the report and for the patch. I applied a slightly modified version to 7.0.x (I fixed the root cause of the NPE) and it will be included in 7.0.12 onwards.