Bug 51100 - tika hangs parsing doc document
tika hangs parsing doc document
Status: RESOLVED FIXED
Product: POI
Classification: Unclassified
Component: POIFS
3.8-dev
PC All
: P2 normal (vote)
: ---
Assigned To: POI Developers List
:
: 51461 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-04-21 05:19 UTC by enricod
Modified: 2011-07-20 11:43 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description enricod 2011-04-21 05:19:50 UTC
Tika (1.0.SNAPSHOT) hangs parsing the word file:

http://dl.dropbox.com/u/2371175/testfile002.doc

The current version of tika (0.9) works fine with the same file

I tested it using POI 3.8-beta2
Comment 1 Nick Burch 2011-04-21 11:37:57 UTC
Fixed in r1095753. IOUtils wasn't handling the case of starting reading from part way into the file, when the file will completely fill the buffer.
Comment 2 Nick Burch 2011-07-20 11:43:15 UTC
*** Bug 51461 has been marked as a duplicate of this bug. ***