Bug 51893 - JMX notification/Exception for empty/exhausted connection pool
JMX notification/Exception for empty/exhausted connection pool
Status: RESOLVED FIXED
Product: Tomcat Modules
Classification: Unclassified
Component: jdbc-pool
unspecified
PC Linux
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-09-26 14:49 UTC by hay_dave
Modified: 2012-03-20 16:44 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hay_dave 2011-09-26 14:49:49 UTC
Currently, if there is an error getting a connection from the pool, a generic SQLException is thrown.  The only way to determine if the problem is a result of the connection pool being exhausted is to catch the SQLException and parse the message (i.e. look for "Pool empty" in ex.getMessage()).  Would like to see the following:

1) A subclass of SQLException thrown in the case of an empty pool
2) A JMX notification sent in the case of an empty pool (e.g. [POOL EXHAUSTED])
Comment 1 Filip Hanik 2012-03-20 16:44:30 UTC
Fixed in r1302990